Bug 481338 - Xorg goes to 100% cpu usage when displaying certain sites
Xorg goes to 100% cpu usage when displaying certain sites
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: xorg-x11-drv-ati (Show other bugs)
5.3
All Linux
high Severity high
: rc
: ---
Assigned To: X/OpenGL Maintenance List
desktop-bugs@redhat.com
: Triaged
Depends On:
Blocks: 928722
  Show dependency treegraph
 
Reported: 2009-01-23 11:24 EST by Alexander Todorov
Modified: 2014-06-09 09:37 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-02-05 20:16:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot of non-reproduction (535.00 KB, image/png)
2009-01-27 20:47 EST, Matěj Cepl
no flags Details
Xorg.0.log (56.41 KB, text/plain)
2009-01-28 09:08 EST, Alexander Todorov
no flags Details
Xorg.conf (1.03 KB, text/plain)
2010-08-28 13:42 EDT, Germano Massullo
no flags Details
Xorg.0.log (40.32 KB, text/plain)
2010-08-28 13:43 EDT, Germano Massullo
no flags Details
dmesg (36.08 KB, text/plain)
2010-08-28 13:44 EDT, Germano Massullo
no flags Details
lshw (17.36 KB, text/plain)
2010-08-28 13:46 EDT, Germano Massullo
no flags Details

  None (edit)
Description Alexander Todorov 2009-01-23 11:24:50 EST
Description of problem:
When running certain applications or displaying some sites with Firefox the Xorg cpu usage will hit the sky and machine starts responding slowly.

Version-Release number of selected component (if applicable):
xorg-x11-server-Xorg-1.1.1-48.52.el5
xorg-x11-drv-ati-6.6.3-3.22.el5

How reproducible:
Always

Steps to Reproduce:
1. Start Firefox and open the url:
http://tauchmeisterwatches.com/military-retro-chronograph-diverswatch-p-400.html

2. Click on "Click to enlarge" under the image to enlarge it.
3. A JavaScript window opens with the larger image. At this moment the CPU usage goes almost to 100%
  
Actual results:
Increased CPU usage, system is responding slowly

Expected results:
No significant change in CPU usage.

Additional info:
I believe this is most likely related to the ati driver but not quite sure. The CPU usage increases when viewing images with fading colors (mostly). It also happens when scrolling down quickly in bugzilla.

lspci on lenovo t60 lists my graphics card as:
01:00.0 VGA compatible controller: ATI Technologies Inc Radeon Mobility X1400


# Xorg configuration created by pyxf86config

Section "ServerLayout"
        Identifier     "Default Layout"
        Screen      0  "Screen0" 0 0
        InputDevice    "Keyboard0" "CoreKeyboard"
        InputDevice    "Synaptics" "CorePointer"
EndSection

Section "InputDevice"
        Identifier  "Keyboard0"
        Driver      "kbd"
        Option      "XkbModel" "pc105"
        Option      "XkbLayout" "us"
EndSection

Section "InputDevice"
        Identifier  "Synaptics"
        Driver      "synaptics"
        Option      "Device" "/dev/input/mice"
        Option      "Protocol" "auto-dev"
        Option      "Emulate3Buttons" "yes"
EndSection

Section "Device"
        Identifier  "Videocard0"
        Driver      "r500"
EndSection

Section "Screen"
        Identifier "Screen0"
        Device     "Videocard0"
        DefaultDepth     24
        SubSection "Display"
                Viewport   0 0
                Depth     24
        EndSubSection
EndSection
Comment 1 Matěj Cepl 2009-01-27 20:47:03 EST
Created attachment 330184 [details]
screenshot of non-reproduction

You can see on the top bar, that CPU (the most left bar indicator in blue) doesn't make any meaningful spike when watching the image enlarged.

Do you have any plugins installed (try to run firefox -safe-mode to check out behavior without them)?
Comment 2 Alexander Todorov 2009-01-28 02:52:02 EST
I don't have any firefox plugins installed and it's reproducible even in safe mode.

Matej,
what's your X configuration and graphics driver? I've observed a terminal executing top and FF clicking on the same url which you attached as non-reproducer. top clearly shows that Xorg is eating the CPU.
Comment 3 Matěj Cepl 2009-01-28 04:25:30 EST
(In reply to comment #2)
> what's your X configuration and graphics driver? I've observed a terminal
> executing top and FF clicking on the same url which you attached as
> non-reproducer. top clearly shows that Xorg is eating the CPU.

Well, "Xorg is eating the CPU" is not exactly what I would say. And you were saying that "Xorg cpu usage will hit the sky and machine starts responding slowly". That's not what I see here. Certainly some Javascript on that page is quite demanding, but the spike in CPU use is just during the page load and it is rather brief one.

Anyway, just to answer you:
[matej@viklef ~]$ lspci |grep -i graph
00:02.0 VGA compatible controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (rev 0c)
00:02.1 Display controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (rev 0c)
[matej@viklef ~]$ 

no xorg.conf
Comment 4 Alexander Todorov 2009-01-28 07:27:12 EST
It's not the javascript on the particular page reported. I get the same CPU spikes when I try to view a presentation in OOo Impress on full screen. Also every time I try scroll the slides back/forward. It takes 5-10 seconds after pressing F5 for the full screen view to show. During that time there's a black screen.

I also get the same spike in CPU load when scrolling quickly through bugzilla.redhat.com and when you have open several bugs and switch between them, yes the machine is quite unusable then.

Matej,
I've clearly stated in comment #0 that I suspect X or the X driver and will appreciate some help trying to narrow down the problem. You claim that you have no problem at all but neither your hardware nor your X configuration is the same as mine so how you know there isn't a problem?
Comment 5 Alexander Todorov 2009-01-28 09:08:33 EST
Created attachment 330228 [details]
Xorg.0.log
Comment 6 Matěj Cepl 2009-01-28 09:32:55 EST
Comment on attachment 330184 [details]
screenshot of non-reproduction

Nonsense, this is RHEL
Comment 8 jghobrial 2009-04-15 16:43:22 EDT
Is there any new information on this?

Not sure if it's the same situation, but I've noticed on a couple of machines with no heavy load, top will show that the Xorg process will hit 1.1G of RES.

In fact on one machine Xorg will slowly increase it's memory footprint over time to > 1G of memory.
Comment 9 Alexander Todorov 2009-04-16 02:53:00 EDT
(In reply to comment #8)
> Is there any new information on this?
> 
> Not sure if it's the same situation, but I've noticed on a couple of machines
> with no heavy load, top will show that the Xorg process will hit 1.1G of RES.
> 

On my machine top doesn't report changes in memory usage even when Xorg uses the cpu at 100%. Probably a different issue.

> In fact on one machine Xorg will slowly increase it's memory footprint over
> time to > 1G of memory.
Comment 11 Alexander Todorov 2010-06-24 13:05:23 EDT
Hi,
I'm setting this to high/high because I'm seeing this quite often with Bugzilla/Firefox now. To reproduce:

Just open any bug in Bugzilla and scroll down quickly using the mouse wheel. The image on screen becomes blurred and CPU usage goes to 100%. Bugzilla scrolls down very slowly. This mostly happens when I scroll down the header section where all flags and stuff is set. 

As QA engineer I work with bugzilla constantly and having those CPU spikes slows down my work quite a lot. Please fix this or give me any guidance how to test and idetify the problem.
Comment 12 Alexander Todorov 2010-06-24 14:39:59 EDT
Changing my Xorg.conf to read Driver "vesa" istead of "r500" caused the CPU spikes to dissapear. Bugzilla and the site referenced in comment #0 are working without significant CPU load. 

I'm changing the component to xorg-x11-drv-ati (version 6.6.3-3.27.el5).
Comment 13 Alexander Todorov 2010-06-24 14:42:26 EDT
Update: when using vesa driver top reports Xorg CPU usage between 10-30-50% which drops almost instantly to 0% when I stop scrolling the page. However system response is much better than before.
Comment 14 Germano Massullo 2010-08-28 13:42:06 EDT
Created attachment 441715 [details]
Xorg.conf
Comment 15 Germano Massullo 2010-08-28 13:43:00 EDT
Created attachment 441717 [details]
Xorg.0.log
Comment 16 Germano Massullo 2010-08-28 13:44:29 EDT
Created attachment 441718 [details]
dmesg
Comment 17 Germano Massullo 2010-08-28 13:46:34 EDT
Created attachment 441719 [details]
lshw
Comment 18 Germano Massullo 2010-08-28 13:47:26 EDT
I have the same problem with Fedora 13 on a Thinkpad T41 with a RV250
The browser is Opera 10.6
I added some attachments
Comment 19 Ludek Smid 2010-11-26 04:15:13 EST
This request was evaluated by Red Hat Product Management for inclusion in a Red Hat Enterprise Linux 5.6 and Red Hat does not plan to fix this issue the currently developed update.

Contact your manager or support representative in case you need to escalate this bug.
Comment 25 RHEL Product and Program Management 2014-02-05 20:16:25 EST
Product Management has reviewed and declined this request.
You may appeal this decision by reopening this request.

Note You need to log in before you can comment on or make changes to this bug.