Bug 481344 - File-roller "semi-compatibility" with Italian Windows .zip archives
File-roller "semi-compatibility" with Italian Windows .zip archives
Status: CLOSED UPSTREAM
Product: Fedora Localization
Classification: Fedora
Component: Italian [it] (Show other bugs)
unspecified
All Linux
low Severity medium
: ---
: ---
Assigned To: Francesco Tombolini
Francesco Tombolini
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-23 11:44 EST by Emanuele Bellini
Modified: 2009-09-21 17:58 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-21 14:43:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
A test file (218 bytes, application/zip)
2009-01-23 11:44 EST, Emanuele Bellini
no flags Details

  None (edit)
Description Emanuele Bellini 2009-01-23 11:44:02 EST
Created attachment 329855 [details]
A test file

Description of problem:
If I put a file with stressed vowels (I mean letters like à è ì ò ù) in a Windows archive and I open it in Linux, I have that I can't extract the file, but I can extract the entire archive (this also happens with archives with several files, I can extract only files without the letters I said).
When I extract the entire archive, of course, the filename lacks of the stressed letter, but I can insert it manually.
I'm not saying File Roller should support various encoding formats (oops... It should!), but at least if I can extract the entire archive, I should be able to extract the single file, am I wrong?


Version-Release number of selected component (if applicable):
file-roller-2.24.2-1.fc10


How reproducible:
Always


Steps to Reproduce:
1.Start Windows;
2.Create two files, one with a stressed vowel and one without it;
3.Select both and right-click over them; select "Send to/Compressed folder";
4.Open the new file in Fedora;

  
Actual results:
I can extract only the file without the stress or the archive, not the one with the "stressed" filename;


Expected results:
I should be able at least to extract it without decompressing the entire archive.
To be quite honest, there should be an encoding detection in file-roller...


Additional info:
I put a copy of a test archive as an attachment.
I created that file with 7-zip, so it isn't a Windows Compressed Folders issue.
Comment 1 Emanuele Bellini 2009-01-23 11:50:03 EST
I've forgotten: am I right to put this thread in the "Localization" section, or should I pass this thread to Fedora developers?
But, more important: have I to write in English when posting a thread about localization, or am I a stupid?
Comment 2 Francesco Tombolini 2009-02-21 14:43:13 EST
Hallo Emanuele, imho this is not a localization specific bug.
You should open a bug against file-roller instead.
If I'm not wrong, file-roller in not a project which fedora is upstream, so if you want, you must file the bug here
http://sourceforge.net/tracker/?group_id=41098&atid=430307
Comment 3 Emanuele Bellini 2009-02-22 09:31:06 EST
Ok, I had to understand that localization bugs aren't related to the working of the program.
I'll try to submit this bug again to this bugzilla... Since I can't take back the status to "new", this is the new bug thread:

https://bugzilla.redhat.com/show_bug.cgi?id=486851

I'll hear what they've to say... See you!

Note You need to log in before you can comment on or make changes to this bug.