Bug 481356 - kernel-2.6.29-0.35.rc1.git4.fc11 and later won't boot (CONFIG_DMAR + buggy BIOS)
kernel-2.6.29-0.35.rc1.git4.fc11 and later won't boot (CONFIG_DMAR + buggy BIOS)
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
low Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F11Blocker/F11FinalBlocker
  Show dependency treegraph
 
Reported: 2009-01-23 12:52 EST by Will Woods
Modified: 2011-06-09 07:08 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-22 15:54:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Will Woods 2009-01-23 12:52:40 EST
The CONFIG_DMAR kernel option, when enabled, can cause x86 machines with buggy BIOSes to refuse to boot.

This config option is required by the KVM PCI Device Assignment feature of Fedora 11 (https://fedoraproject.org/wiki/Features/KVM_PCI_Device_Assignment) and it was (re-)enabled January 13, with kernel kernel-2.6.29-0.35.rc1.git4.fc11. 

If your system fails to boot with that kernel (or any later kernel), try adding "intel_iommu=off" to the boot commandline. If the system boots successfully after that, it is affected by this bug.

If your system is affected by this bug, please add a comment listing the system manufacturer and model. Make sure you're added to the CC list, as we'll need to collect some information from your machine to add it to the kernel blacklist so that it can boot without needing special boot-time arguments.
Comment 1 Tom London 2009-01-23 13:04:46 EST
This sounds related to https://bugzilla.redhat.com/show_bug.cgi?id=479996

My system (Thinkpad X200) booted, but had problems afterwards, including FS corruption.

I "fixed" this by disabling VT-d in the BIOS.

Something else I should do?
Comment 2 Kyle McMartin 2009-01-23 13:57:46 EST
I've disabled this by default in rawhide. Enable it with "intel_iommu=on" until the data corruption by default issues get worked out.

cheers, Kyle
Comment 3 Frank Murphy 2009-01-27 02:58:49 EST
May have something similar, but think I placed it in the wrong bugzilla.

https://bugzilla.redhat.com/show_bug.cgi?id=480667#c11 (c12,13)
Comment 4 Mace Moneta 2009-02-16 23:00:02 EST
I'm having this problem, and have to boot with "intel_iommu=off".  The system is a Supermicro C2SEA motherboard, 8GB RAM, Intel G45/X4500HD:

http://www.smolts.org/client/show/pub_21f31cf1-2c1b-4e8a-860b-01f9d5a43910
Comment 5 Will Woods 2009-02-17 15:30:04 EST
(In reply to comment #4)
> I'm having this problem, and have to boot with "intel_iommu=off".  The system
> is a Supermicro C2SEA motherboard, 8GB RAM, Intel G45/X4500HD:

This option was re-enabled in kernel-2.6.29-0.118.rc5.fc11; what kernel version are you using?
Comment 6 Mace Moneta 2009-02-17 17:28:56 EST
(In reply to comment #5)
> (In reply to comment #4)
> > I'm having this problem, and have to boot with "intel_iommu=off".  The system
> > is a Supermicro C2SEA motherboard, 8GB RAM, Intel G45/X4500HD:
> 
> This option was re-enabled in kernel-2.6.29-0.118.rc5.fc11; what kernel version
> are you using?

I'm now running 2.6.29-0.124.rc5.fc11.x86_64 and I don't need to boot with "intel_iommu=off" anymore.
Comment 7 Kyle McMartin 2009-02-22 15:54:39 EST
It looks like all the issues resulting from intel_iommu are worked out now. (There may still be lingering issues from the DMA API debugging patchset, but those are seperate issues.) Closing this bug now.

Note You need to log in before you can comment on or make changes to this bug.