This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 481380 - ENVRA of pexpect needs to be bumped to obsolete import from EPEL correct
ENVRA of pexpect needs to be bumped to obsolete import from EPEL correct
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: pexpect (Show other bugs)
5.3
All Linux
low Severity medium
: ---
: ---
Assigned To: Marek Grac
BaseOS QE
:
: 452762 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-23 15:26 EST by Robert Scheck
Modified: 2016-04-26 11:28 EDT (History)
3 users (show)

See Also:
Fixed In Version: pexpect-2.3-2.el5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-15 03:21:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robert Scheck 2009-01-23 15:26:46 EST
Description of problem:
The release tag (ENVRA) of the pexpect RPM package in Red Hat Enterprise Linux 
5.3 needs to get bumped from -1 to -2 in order to obsolete the EPEL package 
correct.

The current pexpect RPM package in Red Hat Enterprise Linux was pilfered/
purloined (I got pointed, that "stealing" as I used before is the wrong word 
even if it says the same) from EPEL (Extra Packages for Enterprise Linux), 
where I am/was the long time package maintainer.

The situation is now, if you were using RHEL 5.0 or 5.1 with EPEL and you've 
e.g. installed the duplicity package, the pexpect-2.3-1.el5 package dropped in
from EPEL as dependency. With RHEL 5.2, Red Hat had then decided to put the
pexpect-2.3-1.el5 package into RHEL 5.2, but without any increasing of version
number (maybe it wasn't even rebuilt?).

As "pexpect-2.3-1.el5" from EPEL and "pexpect-2.3-1.el5" from RHEL 5.2 are now
exactly the same, the package never got replaced. So I'm now expecting RHEL
customers out there, that still use the unsupported EPEL package rather the
supported RHEL package. The only way to solve this is, that Red Hat bumps the
release tag from -1 to -2 and pushs an update out to the customer.

As unluckily the regular package maintainer on Red Hat side of pexpect never
showed up on my old bug report #452762 and that guy has shown no reaction to
e-mails in the past too, I'm trying hereby via some Fedora involved Red Hat 
people to get him a clout and maybe somebody of the Red Hat guys can put him 
into a RPM packaging training. Forgetting and/or ignoring such RPM basics when
scrounging a package should never happen.

Note, that I've absolutely no problem with pilfering/purloining/scrounging one
or multiple of my RPM packages, spec files etc., but then please do it correct 
- bump release, add %changelog and stuff...otherwise you shouldn't IMHO be a 
RPM package maintainer.

Version-Release number of selected component (if applicable):
pexpect-2.3-1.el5

How reproducible:
Everytime, see above.

Actual results:
pexpect-2.3-1.el5 from RHEL 5.2+ isn't able to obsolete the original and base
pexpect-2.3-1.el5 package from EPEL and the maintainer on Red Hat side takes
no action; the problem can't be solved by EPEL.

Expected results:
pexpect-2.3-2.el5 in RHEL which supersedes my original and base package from
EPEL.
Comment 1 Robert Scheck 2009-01-23 15:30:01 EST
Looks like the package had a silent owner change in the meantime; Nils 
Philippsen is not the guy I'm complaining hereby about. But Jim Parsons
(jparsons) is the guy, which my inital bug #452762 got assigned to and
who never has shown up to me anywhere, even when trying to contact him.
Comment 2 Robert Scheck 2009-01-24 11:58:24 EST
Bug #481427 is the corresponding bug report for Red Hat Enterprise Linux 4.7.
Comment 3 Marek Grac 2009-08-20 09:09:04 EDT
*** Bug 452762 has been marked as a duplicate of this bug. ***
Comment 4 Marek Grac 2009-08-26 04:08:21 EDT
Package was removed from EPEL (as it should not be in both RHEL+EPEL, ticket #2108).
Comment 5 Marek Grac 2009-08-28 08:55:32 EDT
Patch: only release number will be increased
Comment 13 errata-xmlrpc 2009-10-15 03:21:35 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-1508.html

Note You need to log in before you can comment on or make changes to this bug.