Bug 481383 - Slow repaint of windows with Nvidia GeForce 8200
Slow repaint of windows with Nvidia GeForce 8200
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-nv (Show other bugs)
10
i686 Linux
low Severity high
: ---
: ---
Assigned To: Ben Skeggs
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-23 16:57 EST by Jon Roland
Modified: 2009-02-12 09:01 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-31 02:33:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jon Roland 2009-01-23 16:57:42 EST
Description of problem:
Extremely slow repaint of windows and other displays for both Fedora 9 and Fedora 10 on an HP Pavilion u60-120us laptop with Nvidia GeForce 8200 chipset.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Move or scroll any window
2.
3.
  
Actual results:
Extremely slow repaint of windows.

Expected results:
Fast repaint of windows, allowing for smoothe movement and scrolling.

Additional info:
Problem does not appear lon HP Pavilion dv6775us laptop with Nvidia GeForce 8400M chipset.

Have tried but so far been unable to set up a faster desktop environment like Xfce that might have a faster window manager. The switchdesk xfce command doesn't seem to do anything, although it does not yield and error when executed.

Tried the Nvidia driver "nv" and got no display on reboot, only a train of "ForceXPAon" messaged down the left side of the screen. Went back to the default of "vesa", which at least produces a display, even if a slow one.

xorg.conf is not set for the screen resolution of 1366x768 as it seems to be able to auto-detect it okay.
Comment 1 Jon Roland 2009-01-24 02:25:45 EST
Problem solved. Steps as follows:
Go to http://rpmfusion.org/
Click on Enable RPM Fusion to add the RPM Fusion repositories to your list, both Free and Non-free.
Install xorg-x11-drv-nvidia
Install akmod-nvidia (must do both this and above to make changes effective)
Reboot system.

/etc/X11/xorg.conf gets edited to use the nvidia driver and sets up other parameters.
Fedora 9 now exhibits fairly smooth scrolling and adequate video performance. Could be better but good enough. Now to try it on Fedora 10.
Comment 2 Matěj Cepl 2009-01-24 04:10:23 EST
(In reply to comment #1)
> Problem solved. Steps as follows:
> Go to http://rpmfusion.org/

I believe there should be always a second chance for penitent sinners (just kidding) -- if you clear your computer of all binary-only nvidia stuff (see https://fedoraproject.org/wiki/Xorg/3rd_Party_Video_Drivers), would xorg-x11-drv-nouveau driver work for you?

Otherwise I would have to close this bug as CANTFIX, because we really cannot do anything about computer affected by nvidia stuff (they make changes to much more than just to the driver itself).
Comment 3 Ben Skeggs 2009-01-31 02:33:13 EST
This bug must be related to the binary driver, as both nouveau and nv don't support this chipset yet.  There are open bugs for that problem, so I'll close as CANTFIX for the original bug.
Comment 4 Christian Nolte 2009-02-12 09:01:52 EST
Please try the solution mentioned in this bug report:

https://bugs.launchpad.net/ubuntu/+source/firefox-3.0/+bug/223238/comments/39

It did work for me

Note You need to log in before you can comment on or make changes to this bug.