Bug 481384 - RFE: allow the ability to stack pvs on top of existing mirrors
RFE: allow the ability to stack pvs on top of existing mirrors
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: lvm2 (Show other bugs)
5.3
All Linux
low Severity low
: rc
: ---
Assigned To: Petr Rockai
Cluster QE
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-23 17:27 EST by Corey Marthaler
Modified: 2011-02-09 09:48 EST (History)
10 users (show)

See Also:
Fixed In Version: 2.02.73
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-02-09 09:48:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Corey Marthaler 2009-01-23 17:27:58 EST
Description of problem:
This is a pretty low priority bug, it would be nice to be able to stack pvs on top of mirrors like you can linears. You can not however because the volume header get written to both places and that throws lvm for a loop. You'll end up with "Found duplicate PV" messages and it wont work. 

This is possible if you use filters however. You can filter out mimage* and mlog*.

[root@hayes-03 ~]# pvscan
  Found duplicate PV mK9mPc21WClvcWPtIcGQPQqgHHTzAf6U: using /dev/mapper/vg2-mirror2_mimage_1 not /dev/mapper/vg2-mirror2_mimage_0
  Found duplicate PV mK9mPc21WClvcWPtIcGQPQqgHHTzAf6U: using /dev/vg2/mirror2 not /dev/mapper/vg2-mirror2_mimage_1
  Found duplicate PV zQOZSXuN51TwwrCBU6miKAed3EMod4U0: using /dev/mapper/vg1-mirror1_mimage_1 not /dev/mapper/vg1-mirror1_mimage_0
  Found duplicate PV zQOZSXuN51TwwrCBU6miKAed3EMod4U0: using /dev/vg1/mirror1 not /dev/mapper/vg1-mirror1_mimage_1
  PV /dev/etherd/e1.1p3   VG vg2          lvm2 [1.77 TB / 1.77 TB free]
  PV /dev/etherd/e1.1p4   VG vg2          lvm2 [1.77 TB / 1.77 TB free]
  PV /dev/etherd/e1.1p1   VG vg1          lvm2 [1.77 TB / 1.77 TB free]
  PV /dev/etherd/e1.1p2   VG vg1          lvm2 [1.77 TB / 1.77 TB free]
  PV /dev/vg2/mirror2     VG stacked      lvm2 [1020.00 MB / 1020.00 MB free]
  PV /dev/vg1/mirror1     VG stacked      lvm2 [1020.00 MB / 1008.00 MB free]
  PV /dev/etherd/e1.1p5   VG stacked      lvm2 [1.77 TB / 1.77 TB free]
  PV /dev/sda2            VG VolGroup00   lvm2 [74.38 GB / 0    free]
  Total: 8 [8.94 TB] / in use: 8 [8.94 TB] / in no VG: 0 [0   ]



Version-Release number of selected component (if applicable):
2.6.18-128.el5

lvm2-2.02.40-6.el5    BUILT: Fri Oct 24 07:37:33 CDT 2008
lvm2-cluster-2.02.40-7.el5    BUILT: Wed Nov 26 07:19:19 CST 2008
device-mapper-1.02.28-2.el5    BUILT: Fri Sep 19 02:50:32 CDT 2008
Comment 3 Mikuláš Patočka 2010-10-31 23:37:33 EDT
Apply filter in the config file and it will work. This is really not a bug, but incorrect configuration.
Comment 4 Alasdair Kergon 2010-11-01 07:07:20 EDT
  Found duplicate PV mK9mPc21WClvcWPtIcGQPQqgHHTzAf6U: using
/dev/mapper/vg2-mirror2_mimage_1 not /dev/mapper/vg2-mirror2_mimage_0

Well the code did choose the correct devices to use - just the messages are ugly.

(Did the recent changes concerning not scanning hidden devices in 2.02.73 fix this already?)
Comment 5 Alasdair Kergon 2010-11-01 07:08:27 EDT
(If so, this one is POST.)
Comment 6 Ben Marzinski 2010-11-03 22:43:31 EDT
Mornfall, I assume Alasdair is referring to your "Never scan internal LVM devices." code.
Comment 7 Petr Rockai 2010-11-04 10:51:20 EDT
It should be fixed indeed. Since the fix went into .73, I would believe that it is even fixed in current 5.6 build.
Comment 8 Alasdair Kergon 2011-02-09 09:48:49 EST
Already fixed some time ago: closing.

Note You need to log in before you can comment on or make changes to this bug.