Bug 481401 - PCMCIA Aircard no longer works after kernel upgrade (last working in 2.6.27.5-117.fc10)
PCMCIA Aircard no longer works after kernel upgrade (last working in 2.6.27.5...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
10
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
: 478315 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-23 22:20 EST by Brianna
Modified: 2009-02-23 12:42 EST (History)
6 users (show)

See Also:
Fixed In Version: 2.6.27.15-170.2.24.fc10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-19 18:35:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Log Dump (6.38 KB, text/plain)
2009-01-23 22:21 EST, Brianna
no flags Details
Dump from Working Kernel (5.40 KB, text/plain)
2009-01-29 07:34 EST, Brianna
no flags Details

  None (edit)
Description Brianna 2009-01-23 22:20:34 EST
Description of problem:
After upgrading to the 2.6.27.9-159.fc10 kernel (from 2.6.27.5-117.fc10) my PCMCIA aircard (Verizon PC5750) no longer works.  Network Manager reports "Unable to connect" message (see attached log dump from /var/log/messages ).  Attempt to use gnome-ppp fails as well.
Booting into the 2.6.27.5-117.fc10 kernel (on same machine) and both Network Manager & gnome-ppp are able to connect correctly


Version-Release number of selected component (if applicable):
kernel 2.6.27.9-159.fc10.i686

How reproducible:
100% time in 2.6.27.5-117.fc10

Steps to Reproduce:
1.Plug in PCMCIA card
2.Network manager automatically tries to connect & fails
or
3. Open Terminal - su gnome-ppp
4. attempting to run Setup -> Detect hangs gnome-ppp
5. ctrl-c required in terminal to end gnome-ppp
  
Actual results:
PCMCIA CDMA card unusable/fails to connect

Expected results:
successful connection

Additional info:
partial log file attached.
Comment 1 Brianna 2009-01-23 22:21:22 EST
Created attachment 329899 [details]
Log Dump
Comment 2 Brianna 2009-01-28 09:41:19 EST
Still does not work (same symptoms/errors) after updating kernel to 2.6.27.5-117.fc10.

Only official fedora repo's are used for yum updating. No third party repos are used.

Modified bug summary to be non-version specific.
Comment 3 Chuck Ebbert 2009-01-29 03:00:42 EST
Can you post the logs from a working kernel?
Comment 4 Brianna 2009-01-29 07:34:53 EST
Created attachment 330348 [details]
Dump from Working Kernel
Comment 5 Chuck Ebbert 2009-01-30 17:07:58 EST
ttyUSB0 will not work; the connection needs to be made using ttyUSB1
Comment 6 David Hollis 2009-02-02 11:10:14 EST
How do we tell this to NetworkManager?
Comment 7 Brianna 2009-02-02 13:34:42 EST
I was able to successfully connect using gnome-ppp but only if I manually entered /dev/ttyUSB1 in setup (attempting to use detect still fails & hangs the system).  

Network Manager is still unhappy (but I have to find the correct config info to modify).

Since it appears the naming conventions have changed in the kernel does this need to be listed as a bug in gnome-ppp & Network Manager?
Comment 8 Chuck Ebbert 2009-02-02 18:59:22 EST
(In reply to comment #6)
> How do we tell this to NetworkManager?

I don't know why NM doesn't know to use /dev/ttyUSB1... I'll copy the maintainer.
Comment 9 Chuck Ebbert 2009-02-03 16:38:28 EST
Upstream patch that caused the problem is reverted in 2.6.27.14-170.2.14
Comment 10 Chuck Ebbert 2009-02-19 18:36:21 EST
*** Bug 478315 has been marked as a duplicate of this bug. ***
Comment 11 Brianna 2009-02-23 12:42:55 EST
Updated to Kernel 2.6.27.15-170.2.24.fc10.i686 this past weekend and aircard now works as expected (both with gnome-ppp and NM)

Thanks,
Brianna

Note You need to log in before you can comment on or make changes to this bug.