Bug 481414 - Firefox browser will start always in offline mode.
Firefox browser will start always in offline mode.
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
10
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Gecko Maintainer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-24 03:29 EST by Ivo Sarak
Modified: 2009-01-27 09:37 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-27 09:37:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 418745 None None None Never
Mozilla Foundation 424626 None None None Never

  None (edit)
Description Ivo Sarak 2009-01-24 03:29:35 EST
Description of problem:
Somehow my Firefox does start always in offline mode. I've tried various methods to get rid of it, but still nothing has changed.

Version-Release number of selected component (if applicable):
firefox-3.0.5-1.fc10.x86_64

How reproducible:
Always.

Steps to Reproduce:
1. Start firefox;
2. Check "File->Work Offline" 
 
Actual results:
"Work Offline" is being always set.

Expected results:
No constant offline mode operation by firefox browser.

Additional info:
Comment 1 Ivo Sarak 2009-01-24 03:36:09 EST
about:config does not report as "browser.offline" config option being set by default, but as soon as I disable "Work Offline" mode, it will report "browser.offline user set boolean false". Despite that configuration option on next run of Firefox browser will just ignore it and start in offline mode anyway.
Comment 2 Wayne Channell 2009-01-25 17:56:57 EST
Firefox 3.0.5 always starts up in offline mode.  I installed FC10 from FC8.  The new version of Firefix 3.0.5 starts in offline mode, and always requires the user to click the File --> Work Offline selection in the pulldown window.

[]$ uname -a
Linux hp1.xnet.com 2.6.27.9-159.fc10.i686 #1 SMP Tue Dec 16 15:12:04 EST 2008 i686 i686 i386 GNU/Linux

The same thing happens with the email system.  Evolution 2.24.2 always starts up in offline mode, and it will not remember the email account password.  I always have to click File --> Work Online, and then the system asks for the email account password.  Clicking the Remember Password checkbox has no effect.

It seems like the Firefox and Evolution offline/online startup issues may be related.  By default, the Firefox and Evolution packages should start up in Online mode.
Comment 3 Ivo Sarak 2009-01-26 02:23:57 EST
I upgraded to F10 from F9, but I recall that there was no "firefox offline" issue just after that upgrade. It took some firefox runs to develop it, but I may be wrong...

Still what should we do to get rid of that issue?
Comment 4 Matěj Cepl 2009-01-26 03:53:33 EST
This bug is strange -- there used to be terrible problems on other distros (namely, Ubuntu) with interaction between Firefox and NetworkManager, but I have never seen it in Fedoraland, and it does work for me.

Do you use NetworkManager? What is the value of toolkit.networkmanager.disable value in about:config?
Comment 5 Wayne Channell 2009-01-26 20:50:03 EST
I don't know how to access the about:config information.  How do I do that?  My system uses a 56K modem.  I did not have this problem when I was running FC8.  Under FC7 and FC8 it was very reliable and Firefox and Evolution both always opened up in online mode.  If there is anything that you would like me to try please let me know.

[channmw@hp1 ~]$ rpm -q NetworkManager
NetworkManager-0.7.0-1.git20090102.fc10.i386
Comment 6 Matěj Cepl 2009-01-27 05:49:03 EST
(In reply to comment #5)
> I don't know how to access the about:config information.

I am sorry -- just write it to the firefox URL box (where you normally have the current URL).
Comment 7 Matěj Cepl 2009-01-27 06:27:04 EST
and in the moment when Firefox is offline although your network is up, can we get output of 

nm-tool

command, please?

Thanks a lot.
Comment 9 Ivo Sarak 2009-01-27 08:42:19 EST
For me:
"toolkit.networkmanager.disable default boolean false"
Comment 10 Ivo Sarak 2009-01-27 08:47:42 EST
For me:
[root@ragana ~]# /etc/init.d/NetworkManager status
NetworkManager (pid  2155) is running...
[root@ragana ~]# nm-tool

NetworkManager Tool

State: disconnected

- Device: eth1 ----------------------------------------------------------------
  Type:              Wired
  Driver:            atl1
  State:             disconnected
  Default:           no
  HW Address:        00:23:54:5B:59:4E

  Capabilities:
    Supported:       yes
    Carrier Detect:  yes
    Speed:           100 Mb/s

  Wired Settings


[root@ragana ~]# 

Where does it take that I am disconnected? I am connected.
Is that a LAN driver issue?

If to set "toolkit.networkmanager.disable user set boolean true" then firefox does not start in offline mode.
Comment 11 Matěj Cepl 2009-01-27 09:37:00 EST
(In reply to comment #10)
> - Device: eth1 
>   State:             disconnected

> Where does it take that I am disconnected? I am connected.
> Is that a LAN driver issue?
> 
> If to set "toolkit.networkmanager.disable user set boolean true" then firefox
> does not start in offline mode.

Yeah, OK, so this is really crystal clear duplicate of that upstream Mozilla bug (see External references for the link). Problem (or characteristic) is that NetworkManager is always “all or nothing” solution—either all your network connections are managed by it or none are. And if you try to go in the middle and use NM just for managing wireless networking (many people tried that) you get into unhappy state, where NM seems to be lying.

So, either use NetworkManager for everything (make sure that all ifcfg-* files for devices you use in /etc/sysconfig/network-scripts/ have line saying NM_CONTROLLED=yes), or check the appropriate checkbox in system-config-network), or if you want to manage network connections manually, make sure that configuration files in /etc/sysconfig/network-scripts/ are correct (either manually or via system-config-network) and run (as root)

chkconfig NetworkManager off
service NetworkManager stop
chkconfig network on
service network restart

That firefox setting (toolkit.networkmanager.disable) just switches off Firefox checking the network status from NetworkManager so you have to handle it manually (by switching File/Work Offline).

See the Mozilla bug for more thorough explanation.

Note You need to log in before you can comment on or make changes to this bug.