Bug 481432 - Mail-notification hangs at 100% CPU
Mail-notification hangs at 100% CPU
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: mail-notification (Show other bugs)
10
All Linux
low Severity high
: ---
: ---
Assigned To: Dmitry Butskoy
Fedora Extras Quality Assurance
https://bugs.launchpad.net/mail-notif...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-24 14:08 EST by Laurent Aguerreche
Modified: 2009-01-26 09:02 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-26 09:02:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Laurent Aguerreche 2009-01-24 14:08:03 EST
Description of problem:
If I plug my laptop on its dock station which has a wired connection, MN starts as expected when I am logging on a GNOME session.
If I unplug my laptop to use Wi-Fi then MN will hang at 100% CPU.


How reproducible:
Almost always. Sometimes MN starts but it is unable to connect with a mail server.

Steps to Reproduce:
1. Unplug the network cable
2. Boot your machine
3. Open a session
4. -> NetworkManager is starting to find a Wi-Fi a network to connect to
   -> Mail-notification is starting too and it is perhaps trying to connect to a mail server whereas network is not available
5. mail-notification icon is blinking because none server is available so you have to left-click on the icon and then click on "update"
6. now your CPU usage is at 100%.

Additional info:

A attached a GDB session to mail-notification when it got frozzen:

Loaded symbols for /usr/lib64/libgvfscommon.so.0
0x0000003af80dc886 in __poll (fds=0x1e01280, nfds=6, timeout=0) at ../sysdeps/unix/sysv/linux/poll.c:87
87	  int result = INLINE_SYSCALL (poll, 3, CHECK_N (fds, nfds), nfds, timeout);
Missing separate debuginfos, use: debuginfo-install avahi-0.6.22-11.fc10.x86_64 avahi-0.6.22-12.fc10.x86_64 avahi-glib-0.6.22-11.fc10.x86_64 avahi-glib-0.6.22-12.fc10.x86_64 bug-buddy-2.24.2-1.fc10.x86_64 e2fsprogs-libs-1.41.3-2.fc10.x86_64 elfutils-libelf-0.137-3.fc10.x86_64 expat-2.0.1-5.x86_64 gtk-nodoka-engine-0.7.2-1.fc10.x86_64 gvfs-1.0.3-4.fc10.x86_64 keyutils-libs-1.2-3.fc9.x86_64 krb5-libs-1.6.3-16.fc10.x86_64 libXau-1.0.4-1.fc10.x86_64 libXcomposite-0.4.0-5.fc10.x86_64 libXcursor-1.1.9-3.fc10.x86_64 libXdamage-1.1.1-4.fc9.x86_64 libXdmcp-1.0.2-6.fc10.x86_64 libXext-1.0.4-1.fc9.x86_64 libXfixes-4.0.3-4.fc10.x86_64 libXi-1.1.3-4.fc9.x86_64 libXinerama-1.0.3-2.fc10.x86_64 libXrandr-1.2.3-1.fc10.x86_64 libXrender-0.9.4-3.fc9.x86_64 libcanberra-0.10-2.fc10.x86_64 libcanberra-0.10-3.fc10.x86_64 libcanberra-gtk2-0.10-3.fc10.x86_64 libcap-2.10-2.fc10.x86_64 libgcc-4.3.2-7.x86_64 libgnome-2.24.1-9.fc10.x86_64 libogg-1.1.3-9.fc9.x86_64 libpng-1.2.33-1.fc10.x86_64 libselinux-2.0.73-1.fc10.x86_64 libstdc++-4.3.2-7.x86_64 libtdb-1.1.1-25.fc10.x86_64 libtool-ltdl-1.5.26-4.fc10.x86_64 libvorbis-1.2.0-5.fc10.x86_64 libxcb-1.1.91-5.fc10.x86_64 nss-mdns-0.10-6.fc10.x86_64 openssl-0.9.8g-12.fc10.x86_64 pixman-0.12.0-2.fc10.x86_64
(gdb) bt
#0  0x0000003af80dc886 in __poll (fds=0x1e01280, nfds=6, timeout=0) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x0000003af983ae08 in g_main_context_poll () at gmain.c:3091
#2  g_main_context_iterate (context=0x1d4bdf0, block=1, dispatch=1, self=<value optimized out>) at gmain.c:2773
#3  0x0000003af983b49d in IA__g_main_loop_run (loop=0x1e3c1e0) at gmain.c:2986
#4  0x0000003920923367 in IA__gtk_main () at gtkmain.c:1200
#5  0x000000000042c380 in main (argc=<value optimized out>, argv=0x5) at src/mn-main.c:542
(gdb) c
Continuing.
^C
Program received signal SIGINT, Interrupt.
0x0000003af80dc886 in __poll (fds=0x1e01280, nfds=6, timeout=0) at ../sysdeps/unix/sysv/linux/poll.c:87
87	  int result = INLINE_SYSCALL (poll, 3, CHECK_N (fds, nfds), nfds, timeout);
(gdb) bt
#0  0x0000003af80dc886 in __poll (fds=0x1e01280, nfds=6, timeout=0) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x0000003af983ae08 in g_main_context_poll () at gmain.c:3091
#2  g_main_context_iterate (context=0x1d4bdf0, block=1, dispatch=1, self=<value optimized out>) at gmain.c:2773
#3  0x0000003af983b49d in IA__g_main_loop_run (loop=0x1e3c1e0) at gmain.c:2986
#4  0x0000003920923367 in IA__gtk_main () at gtkmain.c:1200
#5  0x000000000042c380 in main (argc=<value optimized out>, argv=0x5) at src/mn-main.c:542
(gdb) 



Rgds,
Laurent.
Comment 1 Dmitry Butskoy 2009-01-26 09:02:13 EST
It seems to be an old upstream bug, see https://bugs.launchpad.net/mail-notification/+bug/182923 , which is still not fixed. :(

If it is something different, please, reopen.

Note You need to log in before you can comment on or make changes to this bug.