This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 481434 - Symbol U+0431 looks blurry
Symbol U+0431 looks blurry
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: liberation-fonts (Show other bugs)
11
All All
low Severity medium
: ---
: ---
Assigned To: Caius Chance
Fedora Extras Quality Assurance
: i18n
Depends On:
Blocks: 485746
  Show dependency treegraph
 
Reported: 2009-01-24 14:17 EST by Sergei Stolyarov
Modified: 2009-07-01 10:40 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-30 22:40:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
The difference before old and new glyph. (5.53 KB, image/png)
2009-01-24 14:17 EST, Sergei Stolyarov
no flags Details

  None (edit)
Description Sergei Stolyarov 2009-01-24 14:17:48 EST
Created attachment 329915 [details]
The difference before old and new glyph.

Description of problem:
Symbol U+0431 (russian letter “б”) looks bad since revision 877cd82cc8ef4b7f9f1b3645ad0dd54efe60e3fb. In that revision glyph's shape was altered but hint instructions were not.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
Render string containing symbol "б" with antialiasing turned on and compare with revision before 877cd82cc8ef4b7f9f1b3645ad0dd54efe60e3fb.
  
Actual results:


Expected results:
Normal shape is expected.

Additional info:
Comment 1 Sergei Stolyarov 2009-01-24 14:27:50 EST
The font is Libertion Sans.
Comment 2 Caius Chance 2009-01-28 02:35:57 EST
https://fedorahosted.org/liberation-fonts/browser/trunk/src/LiberationSans-Regular.sfd

has hinting instructions within U+0431.

afaik, only hinting is affected by hinting instructions.

Which software have you used to generate screenshot?
Comment 3 Sergei Stolyarov 2009-01-28 14:58:14 EST
I used gimp 2.6.3 from Debian. But this symbol looks blurry in all programms.

Afaik hints should be rewritten if glyph's shape changed. At least fontforge shows message this when changing any glyph with hints that hints will be removed.
Comment 4 Bug Zapper 2009-06-09 06:52:56 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 5 Caius Chance 2009-06-30 22:40:45 EDT
Zap this bug. Please open this if bug persists after testing.
Comment 6 Sergei Stolyarov 2009-07-01 10:40:13 EDT
Just checked version liberation-fonts-ttf-1.05.1.20090630.zip, everything is looking fine.

Note You need to log in before you can comment on or make changes to this bug.