Bug 481436 - Quagga obsoletes bird (and others), but why?
Quagga obsoletes bird (and others), but why?
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: quagga (Show other bugs)
10
All Linux
low Severity high
: ---
: ---
Assigned To: Jiri Skala
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-24 16:43 EST by Skippy
Modified: 2014-11-09 17:31 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-14 07:58:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Skippy 2009-01-24 16:43:38 EST
I'm trying to use Bird, a routing daemon. I've got an RPM from the Bird site.

The quagga RPM however obsoletes bird, so when ever I do yum update, bird disappears.

From the spec file for Quagga:
Obsoletes:	bird gated mrt zebra

Why? I thought the obsoletes tag was just to help upgraders. This doesn't help at all. I don't imagine zebra or gated users will be overjoyed either.
Comment 1 Jiri Skala 2009-02-02 09:05:21 EST
Usage of obsoletes is an intention. The quagga contains zebra that provides the same functionality as the other packages. The other are uninstalled.
Comment 2 Skippy 2009-02-02 11:59:22 EST
Booooooo!

Why does postfix not obsolete sendmail then (or sendmail obsolete postfix). They "provides the same functionality as the other packages". Or openoffice and gnumeric. And ipsec-tools and openswan. I can go on :-)

I can see why quagga might obselete zebra, since they both use a similar configuration language. But I don´t see why it should obsolete bird.
Comment 3 Jiri Skala 2009-07-14 07:58:33 EDT
done

Note You need to log in before you can comment on or make changes to this bug.