Bug 481455 - ppc32 can't boot with newer rawhide kernels
ppc32 can't boot with newer rawhide kernels
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
powerpc Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-24 22:30 EST by Kevin Fenzi
Modified: 2009-02-12 17:12 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-12 17:12:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kevin Fenzi 2009-01-24 22:30:21 EST
rawhide kernels including kernel-2.6.29-0.28.rc1.fc11.ppc and after don't seem to allow a normal boot on my ppc32 g4 machine.

The kernel loads and boots, but when it gets to: 

Setting up Logical Volume Management:

it locks completely. 
Adding in a strace I see it's stuck in a read of /dev/cdrom1
However, this machine only has a single cdrom, which on working kernels is just /dev/cdrom. 

Can anyone duplicate this?
Is there further info I can provide?

Smolt profile: http://www.smolts.org/client/show/pub_f3216f28-fbb5-4888-af2e-0d3f0eb3a55c
Comment 1 Jarod Wilson 2009-01-29 14:59:44 EST
So... kernel-2.6.29-0.69.rc3.fc11.ppc boots just fine on my powerbook, which has a fully updated F10 + the aforementioned rawhide kernel on it. Could be some bad interaction between the rawhide kernel and rawhide lvm though, guess I should go raw-er on my powerbook...
Comment 2 Jarod Wilson 2009-01-29 16:32:26 EST
Whoops, meant to add myself to the cc list... I've got a sacrificial G4 tower in the office I'll try to reproduce on, hopefully tomorrow...
Comment 3 Kevin Fenzi 2009-02-11 23:00:13 EST
Strange. 

Just rebooted into 2.6.29-0.99.rc4.git1.fc11.ppc and it worked. 

All I can figure is that it was some unspecified rawhide breakage that got fixed. ;( 

Should we try and track it down more? or just be thankfull and move on?
Either is fine with me.
Comment 4 Jarod Wilson 2009-02-12 17:01:21 EST
Turns out there was a ppc32-smp-specific bug biting me, in addition to some apparent video hardware related issues tripping up plymouth... But I finally have a rawhide kernel booting on my dual 800 G4 tower, after adding a patch jwb pointed me at:

http://patchwork.ozlabs.org/patch/22887/

Going to tack that onto rawhide in a sec, but I suspect it'll get into linus' tree RSN.
Comment 5 Jarod Wilson 2009-02-12 17:03:00 EST
Never mind, its already in linus' tree, we'll just pick it up from the next git snap rebase.
Comment 6 Jarod Wilson 2009-02-12 17:12:13 EST
So yeah, lets just chalk this up to development kernel churn and close it for now...

Note You need to log in before you can comment on or make changes to this bug.