This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 481475 - nfs-utils-1.1.4-6, unmountable nfs shares
nfs-utils-1.1.4-6, unmountable nfs shares
Status: CLOSED DUPLICATE of bug 480223
Product: Fedora
Classification: Fedora
Component: nfs-utils (Show other bugs)
10
i386 Linux
low Severity urgent
: ---
: ---
Assigned To: Steve Dickson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-25 08:51 EST by Sameer Naik
Modified: 2009-01-30 06:37 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-30 06:37:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Sameer Naik 2009-01-25 08:51:52 EST
Description of problem:
updating to nfs-utils-1.1.4-6, leaves nfs mountpoints unmountable 

Version-Release number of selected component (if applicable):
1.1.4-6

How reproducible:
Install nfs-utils-1.1.4-6, try to mount nfs share

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
When i updated to nfs-utils-1.1.4-6, my nfs shares became unmountable. I use an nfs share on my fedora 10 host as the root filesystem of an embedded system.
after updating nfs-utils the board is no longer able to boot since its not being able to mount the nfs share throwing the forllong message

Root-NFS: Server returned error -5 while mounting /home/sameersbn/workdir/filesys         
VFS: Unable to mount root fs via NFS, trying floppy.                                      
VFS: Cannot open root device "nfs" or unknown-block(2,0)                                  
Please append a correct "root=" boot option                                               
Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(2,0)

After downgrading to nfs-utils-1.1.4-1, everythings alright
Comment 1 Axel Thimm 2009-01-29 16:52:20 EST
Are your clients' IP registered with DNS? If not you are hitting bug #480420 which was marked as a duplicate of bug #480223.
Comment 2 Sameer Naik 2009-01-29 23:35:47 EST
The nfs clients ip is acquired via DHCP and there is neither a nameserver entry either on the DNS Server nor on the Nfs Hosts /etc/hosts file.

As mentioned in the bug report, the nfs mounting was happening perfectly until i upgraded nfs-utils. Right now i have downgraded back to the release version of nfs-utils and everythings perfect.
Comment 3 Axel Thimm 2009-01-30 06:37:27 EST
Then it's the same bug as bug #480420. All these reports are gathered now at bug #480223.

*** This bug has been marked as a duplicate of bug 480223 ***

Note You need to log in before you can comment on or make changes to this bug.