Fedora Account System
Red Hat Associate
Red Hat Customer
Description of problem: updating to nfs-utils-1.1.4-6, leaves nfs mountpoints unmountable Version-Release number of selected component (if applicable): 1.1.4-6 How reproducible: Install nfs-utils-1.1.4-6, try to mount nfs share Steps to Reproduce: 1. 2. 3. Actual results: Expected results: Additional info: When i updated to nfs-utils-1.1.4-6, my nfs shares became unmountable. I use an nfs share on my fedora 10 host as the root filesystem of an embedded system. after updating nfs-utils the board is no longer able to boot since its not being able to mount the nfs share throwing the forllong message Root-NFS: Server returned error -5 while mounting /home/sameersbn/workdir/filesys VFS: Unable to mount root fs via NFS, trying floppy. VFS: Cannot open root device "nfs" or unknown-block(2,0) Please append a correct "root=" boot option Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(2,0) After downgrading to nfs-utils-1.1.4-1, everythings alright
Are your clients' IP registered with DNS? If not you are hitting bug #480420 which was marked as a duplicate of bug #480223.
The nfs clients ip is acquired via DHCP and there is neither a nameserver entry either on the DNS Server nor on the Nfs Hosts /etc/hosts file. As mentioned in the bug report, the nfs mounting was happening perfectly until i upgraded nfs-utils. Right now i have downgraded back to the release version of nfs-utils and everythings perfect.
Then it's the same bug as bug #480420. All these reports are gathered now at bug #480223. *** This bug has been marked as a duplicate of bug 480223 ***