Bug 481510 - No MIC Capture and Input Source after kernel update to kernel-2.6.27.9-159.fc10.x86_64
No MIC Capture and Input Source after kernel update to kernel-2.6.27.9-159.fc...
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
10
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-25 15:40 EST by Kornienko Sergey
Modified: 2009-01-27 16:24 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-27 16:24:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kornienko Sergey 2009-01-25 15:40:56 EST
Hello all !
 
Hardware: Samsung Q45, Intel GMA965, sound use snd_hda_intel module, alsamixer -c0 report Card: HDA Intel, Chip: Realtek ALC262, lspci report: 
"00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller (rev 03)" 
http://www.smolts.org/client/show/pub_dbe4d868-5309-4f65-a2ba-bb5767a23851

Software:
kernels: kernel-2.6.27.9-159.fc10.x86_64 and kernel-2.6.27.7-134.fc10.x86_64
primary kernel now: kernel-2.6.27.7-134.fc10.x86_64
DE: KDE 4.1.4

Big thank WujekEuzebiusz from LinuxQuestions.

Description of problem:

http://www.linuxquestions.org/questions/linux-newbie-8/fedora-10-no-sound-690121/page2.html
I spent the most of today tracking the source of problems with no capture / low capture levels when capturing sound from the microphone using ALSA+PulseAudio. The effect was as if the microphone input were "nearly muted". My findings indicate that the kernel update from 2.6.27.7-134 to 2.6.27.9-159 may be at fault (I didn't analyse the corresponding source diffs yet).

The configuration is FC10.x86_64 on AMD64 (Athlon64 X2), Gnome UI, ULI M5461 with ALC861 chipset (driver module: snd-hda-intel), kernels 2.6.27.7-134.fc10.x86_64 and 2.6.27.9-159.fc10.x86_64. All binaries and libs were reinstalled from scratch on Dec 24 from the FC10 live DVD, then the system was fully updated from the net.

Under kernel 2.6.27.9-159.fc10.x86_64, ALSA mixers show no capture controls, neither in textual mode ("alsamixer -c0", then F4) nor in graphical mode ("gnome-volume-control" with "HDA ULI M5461 (Alsa mixer)" selected).

By simply rebooting into kernel 2.6.27.7-134, the capture controls reappeared in both textual and graphical mixer UI, and capture volume control works OK again. This was checked with both gnome-sound-recorder and Skype (2.0.0.72 static for i386).

Looks like we have to stick with the kernel 2.6.27.7-134 for the time being, as per the information from bozo_the_clown above.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Update kernel to kernel-2.6.27.9-159.fc10.x86_64
2. Reboot
3. Start your DE KDE or Gnome and run mixer
4. On kernel-2.6.27.9-159.fc10.x86_64 you can't see Capture channel and Input Source and Skype or Audacity don't capture sound.
5. Reboot to kernel-2.6.27.7-134.fc10.x86_64
3. Start your DE KDE or Gnome and run mixer
4. On this kernel you can see Capture channel and you can take as Input Source Mic or Front Mic.

  
Actual results:


Expected results:


Additional info:
Comment 1 Kornienko Sergey 2009-01-27 16:24:38 EST
Today I'm update my system with new kernel from default repos, now current version stable kernel-2.6.27.12-170.2.5.fc10.x86_64. This problem was gone. Thank you very much, all developers ! :)

Note You need to log in before you can comment on or make changes to this bug.