Bug 481542 - remote firefox should access remote files, not local firefox
remote firefox should access remote files, not local firefox
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Gecko Maintainer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-26 03:24 EST by Christopher Beland
Modified: 2018-04-11 13:45 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-26 03:56:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christopher Beland 2009-01-26 03:24:03 EST
I am running firefox-3.0.5-1.fc9.i386 on my local machine.  I use "ssh -Y" to start a session on a remote machine, and then run "firefox file:///usr/share/doc/geeqie-1.0alpha2/html/index.html" to access that documentation on the remote machine with firefox-3.1-0.4.beta2.fc11.x86_64.

Instead of a remote firefox instance starting up, the local firefox instance (which is already running) opens a new window, and attempts to access that file on my local machine.  This fails because the file does not exist.  

This also affects firefox instances started from other remote programs, for example by activating the "Help" feature from a GUI application menu.
Comment 1 Matěj Cepl 2009-01-26 03:56:43 EST
When running remote firefox, it has to be run with -no-remote paramter on the command line.

I don't like this behavior eithr, but it won't be changed (for various reasons), and so for now, I have to treat as your configuration error.

I am sorry.
Comment 2 Christopher Beland 2009-01-28 03:33:35 EST
I am specifically having a problem with "Help -> Contents" in geeqie. Unfortunately, -no-remote has its own problems.  It works the first time "Help -> Contents" is selected, but the second time, it produces the error:

 Firefox is already running, but is not responding. To open a new window, you must first close the existing Firefox process, or restart your system.

I'm not sure how geeqie can fix this.  It seems obvious enough to me that the current behavior is simply wrong for all file:// URLs, silently showing the local copy of the file (if any) instead of the remote one.  Where can I find more information about why this cannot be fixed in firefox, and in what case this is actually a good idea?
Comment 3 Matěj Cepl 2009-01-28 04:40:04 EST
Please, file a bug upstream about that confused Help.

Note You need to log in before you can comment on or make changes to this bug.