Bug 481552 - HorizEdgeScroll and VertEdgeScroll are not handled correctly
HorizEdgeScroll and VertEdgeScroll are not handled correctly
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gsynaptics (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Andreas Thienemann
Fedora Extras Quality Assurance
:
: 489648 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-26 05:32 EST by Zdenek Kabelac
Modified: 2009-04-14 01:11 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-14 01:11:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Zdenek Kabelac 2009-01-26 05:32:58 EST
Description of problem:

gsynaptics reports wrong values for HorizEdgeScroll and VertEdgeScroll and is not able to set them according to user settings. If they are 'off'  (which is currenct xorg default) - they are shown as enabled. If they are turned on by xorg config/synclient and I want to turn them off by gsynaptics no change is done (i.e. synclient -l  shows the same value)

Version-Release number of selected component (if applicable):
gsynaptics-0.9.14-2.fc10.x86_64

How reproducible:


Steps to Reproduce:
1. synclient -l | grep HorizEdgeScroll
2. check if this matches to values shown in gsynaptics
3. via synclient change the HorizEdgeScroll to the opposite value
4. check if there is any change in gsynaptics
5. try to make a change with gsynaptics
6. control the change with synclient -l | grep HorizEdgeScroll
  
Actual results:


Expected results:


Additional info:
Comment 1 Peter Hutterer 2009-03-22 20:44:02 EDT
*** Bug 489648 has been marked as a duplicate of this bug. ***
Comment 2 Peter Hutterer 2009-03-22 20:56:15 EDT
Test package available at: http://koji.fedoraproject.org/scratch/whot/task_1253517/

I don't have ACLs to commit it yet.
Comment 3 Jason Merrill 2009-03-27 15:02:33 EDT
That package works for me.
Comment 4 Jiri Cerny 2009-03-29 06:06:06 EDT
I had the same problem. The package from #2 works for me.
Comment 5 Zdenek Kabelac 2009-03-30 07:40:59 EDT
I've updated gsynaptics and now synclient and gsynaptics are showing the same value - but for some reason  both Horiz & VertEdgeScroll seem to be always active even when they should be actually disabled now - not so sure why this happens - will explore later....
Comment 6 Jiri Cerny 2009-04-01 03:09:26 EDT
Additional remark to my comment #4. With the package from #2 I can use gsynaptics to enable tapping and vertical scrolling. However, the setting is not persistent, i.e. when I reboot, I should enable them again.
Comment 7 Zdenek Kabelac 2009-04-01 04:35:14 EDT
I may suggest to use these options:

        Option      "VertEdgeScroll" "1"
        Option      "HorizEdgeScroll" "1"

Put them into you xorg.conf InputDevice section for your synaptics.

Hmm maybe this could be the reason, why I'm having them always enabled now?
(i.e. I cannot turn them off)
Comment 8 Jiri Cerny 2009-04-01 04:45:52 EDT
Thanks for the suggestion. I can live with enabling them every morning again (if it does not last for ever). There is some obvious error in gsynaptics. It is instructive to start gsynaptics and gconf-editor at the same time, go to /desktop/gnome/peripherals/touchpad and start to play with gsynaptics.  E.g.

Clicking Enable Tapping does not change any key
Clicking Enable Vertical Scrolling changes vertical_scroll_delta from 0 to 1
Sliding Vertical Scrolling speed slider changes vertical_scroll_enabled 
....
Comment 9 Peter Hutterer 2009-04-01 05:03:28 EDT
(In reply to comment #8)
> Thanks for the suggestion. I can live with enabling them every morning again
> (if it does not last for ever). 

gsynaptics actually says you need to start it to enable the gconf keys. obviously some better integration with gnome would be good. on the todo list, like so many other things.

> There is some obvious error in gsynaptics. It
> is instructive to start gsynaptics and gconf-editor at the same time, go to
> /desktop/gnome/peripherals/touchpad and start to play with gsynaptics.  E.g. 

> Clicking Enable Tapping does not change any key

oops. i'll fix this, thanks.

> Clicking Enable Vertical Scrolling changes vertical_scroll_delta from 0 to 1
> Sliding Vertical Scrolling speed slider changes vertical_scroll_enabled

I found and fixed these two today, simple copy/paste error. once the commit is through it'll be gone.

I've got another set of changes queued to select between edge/twofinger scrolling too.
Comment 10 Peter Hutterer 2009-04-01 20:42:40 EDT
Fixed with 0.9.14-5 (except for the enable tapping gconf key, I'm working on this right now)

http://koji.fedoraproject.org/koji/taskinfo?taskID=1271795
Comment 11 Peter Hutterer 2009-04-14 01:11:51 EDT
fixed with 0.9.16-1

Note You need to log in before you can comment on or make changes to this bug.