Bug 481557 - ifdown of vlan iface which is a bridge member, does not take vlan iface down
ifdown of vlan iface which is a bridge member, does not take vlan iface down
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: initscripts (Show other bugs)
5.3
All Linux
medium Severity medium
: rc
: ---
Assigned To: initscripts Maintenance Team
BaseOS QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-26 06:20 EST by Dan Kenigsberg
Modified: 2014-09-08 07:25 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-02 07:13:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
continue ifdow after iface is removed from bridge (348 bytes, patch)
2009-01-26 06:20 EST, Dan Kenigsberg
no flags Details | Diff

  None (edit)
Description Dan Kenigsberg 2009-01-26 06:20:52 EST
Created attachment 329973 [details]
continue ifdow after iface is removed from bridge

Description of problem:
if a vlan device (say eth0.7) is a member of a bridge (say br0), ifdown eth0.7 removes eth0.7 from br0, but does not take eth0.7 interface down. To do that, you have to manually vconfig rem eth0.7.

Version-Release number of selected component (if applicable):
8.45.25-1.el5 (but also in Fedora's initscripts-8.86-1)

How reproducible:
always.

Steps to Reproduce:
1. in /etc/sysconfig/network-scripts/ifcfg-eth0.7 have
DEVICE=eth0.7
ONBOOT=yes
VLAN=yes
BOOTPROTO=none
BRIDGE=br0

2. in /etc/sysconfig/network-scripts/ifcfg-br0
DEVICE=br0
TYPE=Bridge
ONBOOT=yes
GATEWAYDEV=none

3. service network restart

4. ifdown eth0.7

Actual results:
ifconfig eth0.7 showing it's still up

Expected results:
eth0.7 down.

Additional info:
the reason for this is that /etc/sysconfig/network-scripts/ifdown stops all processing after it disconnected eth0.7 from br0.
Comment 1 Bill Nottingham 2009-01-26 09:46:24 EST
Looks OK.
Comment 4 Fedora Update System 2009-04-02 14:04:45 EDT
initscripts-8.86.1-1 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/initscripts-8.86.1-1
Comment 5 Fedora Update System 2009-04-03 00:16:26 EDT
initscripts-8.86.2-1 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/initscripts-8.86.2-1
Comment 6 Fedora Update System 2009-04-22 16:22:55 EDT
initscripts-8.86.3-1 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 7 Harald Hoyer 2009-05-05 08:52:21 EDT
Please test the erratum candidate:
http://people.redhat.com/harald/downloads/initscripts/initscripts-8.45.26.1.el5/
Comment 9 Miroslav Vadkerti 2009-07-16 16:22:28 EDT
Can't reproduce this bug with initscripts-8.45.25-1.el5 and bridge-utils-1.1-2:

[root@intel-d3c4702-01 ~]# cat /etc/sysconfig/network-scripts/ifcfg-eth0.7 
DEVICE=eth0.7
ONBOOT=yes
VLAN=yes
BOOTPROTO=none
BRIDGE=br0

[root@intel-d3c4702-01 ~]# cat /etc/sysconfig/network-scripts/ifcfg-br0
DEVICE=br0
TYPE=Bridge
ONBOOT=yes
GATEWAYDEV=none

[root@intel-d3c4702-01 ~]# service network restart
Shutting down interface br0:  [  OK  ]
Shutting down interface eth0:  [  OK  ]
Shutting down loopback interface:  [  OK  ]
Bringing up loopback interface:  [  OK  ]
Bringing up interface eth0:  
Determining IP information for eth0... done. [  OK  ]
Bringing up interface eth0.7:  [  OK  ]
Bringing up interface br0:  [  OK  ]

[root@intel-d3c4702-01 ~]# ifconfig eth0.7
eth0.7    Link encap:Ethernet  HWaddr 00:13:20:F3:F0:C5  
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:64 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:0 (0.0 b)  TX bytes:18540 (18.1 KiB)

[root@intel-d3c4702-01 ~]# ifdown eth0.7

[root@intel-d3c4702-01 ~]# ifconfig eth0.7
eth0.7    Link encap:Ethernet  HWaddr 00:13:20:F3:F0:C5  
          BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:64 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:0 (0.0 b)  TX bytes:18540 (18.1 KiB)

The device is down, failed to reproduce, any idea if anything went wrong?
Comment 10 Dan Kenigsberg 2009-07-16 16:59:34 EDT
(In reply to comment #9)
> The device is down, failed to reproduce, any idea if anything went wrong?  

what went wrong is my liberal use of the terms 'up' and 'down'.

if you define eth0.7 with no relation to any bridge, bring it up, and finally ifdown, the vlan interface is removed. not shown at all by ifconfig.

this is in contrast to what used to be the case if eth0.7 was enslaved to a bridge: eth0.7 still exists after ifdown.
Comment 12 Miroslav Vadkerti 2009-07-17 01:06:08 EDT
added RHTS test CoreOS/initscripts/Regression/bz481557-ifdown-does-not-take-vlan-down
Comment 14 errata-xmlrpc 2009-09-02 07:13:47 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-1344.html

Note You need to log in before you can comment on or make changes to this bug.