Bug 481563 - RFE: Schedular params: support persistence of schedular parameters in XML
RFE: Schedular params: support persistence of schedular parameters in XML
Status: CLOSED CURRENTRELEASE
Product: Virtualization Tools
Classification: Community
Component: libvirt (Show other bugs)
unspecified
All All
low Severity medium
: ---
: ---
Assigned To: Daniel Veillard
:
Depends On:
Blocks: libvirtTodoHV
  Show dependency treegraph
 
Reported: 2009-01-26 07:04 EST by John Levon
Modified: 2011-07-07 10:34 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-07-07 10:34:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Levon 2009-01-26 07:04:07 EST
Description of problem:

schedinfo, and the underlying API, does not persist its configuration. A number of problems exist:

- the current code does not correctly refuse to work on a shutdown domain with a nice message
- the xenstore code doesn't quietly fail to work on a shutdown domain
- the xend code doesn't work due to a xend bug (need a xend fix plus a libvirt fix)
- the XML does not have any representation of scheduler params
Comment 1 Daniel Berrange 2011-07-07 10:34:30 EDT
Sched parameters are now persisted in the XML and will work offline (if the driver in question supports it).

commit b8853925faccdecd59655142b61bdcd00716e03a
Author: Osier Yang <jyang@redhat.com>
Date:   Tue Mar 29 21:34:18 2011 +0800

    cputune: Implementations of parsing and formating cputune xml

Note You need to log in before you can comment on or make changes to this bug.