Bug 481591 - 1280x1024 impossible if VGA not attached during boot
1280x1024 impossible if VGA not attached during boot
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-i810 (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-26 11:18 EST by Andrew Overholt
Modified: 2009-05-19 15:21 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-19 15:21:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg.log from booting outside dock and then docking (202.20 KB, text/plain)
2009-01-26 11:18 EST, Andrew Overholt
no flags Details
Xorg.log from booting in the dock (308.98 KB, text/plain)
2009-01-26 11:19 EST, Andrew Overholt
no flags Details
Xorg.log from booting outside dock *with* attached VGA cable (307.14 KB, text/plain)
2009-01-26 11:19 EST, Andrew Overholt
no flags Details
Xorg.log after booting outside dock *withOUT* attached VGA cable (225.54 KB, text/plain)
2009-01-26 11:20 EST, Andrew Overholt
no flags Details

  None (edit)
Description Andrew Overholt 2009-01-26 11:18:34 EST
Created attachment 329995 [details]
Xorg.log from booting outside dock and then docking

Description of problem:
If I boot my laptop (Thinkpad x61) with my 19" 1280x1024-capable monitor *not* connected to my laptop, I cannot make X display 1280x1024.  Booting it with the monitor connected makes this possible.

Version-Release number of selected component (if applicable):
2.5.0-4.fc10.x86_64

How reproducible:
Always.

Steps to Reproduce:
1. Boot with VGA cable to 1280x1024-capable monitor disconnected
2. xrandr --addmode VGA 1280x1024
  
Actual results:
xrandr: cannot find mode "1280x1024"

Expected results:
xrandr --output VGA 1280x1024 => 1280x1024 on my external monitor

Additional info:
I tried this both through the dock and directly attached to the laptop.  The results were the same in both cases.  I also did it with and without suspending first and it was the same in both cases.  If I boot it *in* the dock (or with VGA attached directly), xrandr -q gives:

$ xrandr -q
Screen 0: minimum 320 x 200, current 1024 x 768, maximum 1400 x 1400
VGA connected 1024x768+0+0 (normal left inverted right x axis y axis) 376mm x 301mm
   1280x1024      60.0 +   75.0     60.0
   1400x1050      60.0
   1280x960       60.0
   1152x864       75.0
   1024x768       75.0     70.1     60.0*
   832x624        74.6
   800x600        72.2     75.0     60.3     56.2
   640x480        75.0     72.8     75.0     59.9
   720x400        70.1
LVDS connected 1024x768+0+0 (normal left inverted right x axis y axis) 246mm x 185mm
   1024x768       50.0*+   60.0     40.0
   800x600        60.3     56.2
   640x480        59.9
$ xrandr --addmode VGA 1280x1024
$ xrandr --output VGA --mode 1280x1024

Booting outside the dock (or without VGA attached) and then attaching gives:

$ xrandr -q
Screen 0: minimum 320 x 200, current 1024 x 768, maximum 1024 x 1024
VGA connected (normal left inverted right x axis y axis)
   1024x768       75.0     70.1     60.0  
   832x624        74.6  
   800x600        72.2     75.0     60.3     56.2  
   640x480        75.0     72.8     75.0     59.9  
   720x400        70.1  
LVDS connected 1024x768+0+0 (normal left inverted right x axis y axis) 246mm x 185mm
   1024x768       50.0*+   60.0     40.0  
   800x600        60.3     56.2  
   640x480        59.9  
$ xrandr --addmode VGA 1280x1024
xrandr: cannot find mode "1280x1024"
Comment 1 Andrew Overholt 2009-01-26 11:19:03 EST
Created attachment 329996 [details]
Xorg.log from booting in the dock
Comment 2 Andrew Overholt 2009-01-26 11:19:48 EST
Created attachment 329997 [details]
Xorg.log from booting outside dock *with* attached VGA cable
Comment 3 Andrew Overholt 2009-01-26 11:20:18 EST
Created attachment 329998 [details]
Xorg.log after booting outside dock *withOUT* attached VGA cable
Comment 4 Andrew Overholt 2009-01-26 11:20:39 EST
I have no /etc/X11/xorg.conf
Comment 5 Adam Jackson 2009-05-19 15:21:42 EDT
Observations:

1) In F11 this won't be an issue, KMS means you can dynamically resize the framebuffer to larger than 1024 square.

2) You can statically allocate a larger framebuffer with the Virtual keyword in xorg.conf.

3) --addmode adds an existing named mode to an output.  It does not create new named modes.  Use --newmode to do that, and generate the timings for --newmode from the cvt utility.  But, since the virtual size is limited in F10 if you start X without the VGA attached, you'll need to see 2) above to force it to work.

So, not really a bug, just expected (albeit lame) behaviour.

Note You need to log in before you can comment on or make changes to this bug.