Bug 481595 - system-config-lvm doesn't see the Logical Volume as mounted
system-config-lvm doesn't see the Logical Volume as mounted
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: lvm2 (Show other bugs)
10
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: LVM and device-mapper development team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-26 11:48 EST by Nicolas Chauvet (kwizart)
Modified: 2009-02-26 11:11 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-26 11:11:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nicolas Chauvet (kwizart) 2009-01-26 11:48:39 EST
Description of problem: when using system-config-lvm. The tool doesnt see the Logical Volume as mounted (despite they are).


Version-Release number of selected component (if applicable):
lvm2-2.02.39-7.fc10.x86_64
device-mapper-1.02.27-7.fc10.x86_64
setup-2.7.4-2.fc10.noarch
system-config-lvm-1.1.4-3.1.fc10.noarch

How reproducible:
always

Steps to Reproduce:
1. run system-config-lvm
2. browse to the logical view of any LogVol?? (for example the "/" ones)
3. look at the property for such Logical Volume. At the mounting point it says "not mounted" despite it is the "/" filesystem. Mount point after reboot is set to "None".
  
Actual results: The tool doesn't see the Logical Volumes as mounted,( None are seen as such).


Expected results: It should have seen the mounted partitions


Additional info:
[root@kwizatz ~]# uname -r
2.6.27.9-159.fc10.x86_64
(I cannot boot on 2.6.27.12-170.2.5.fc10.x86_64 )

[root@kwizatz ~]# mount
/dev/dm-9 on / type ext3 (rw)
/proc on /proc type proc (rw)
sysfs on /sys type sysfs (rw)
devpts on /dev/pts type devpts (rw,gid=5,mode=620)
tmpfs on /dev/shm type tmpfs (rw)
/dev/dm-7 on /boot type ext3 (rw)
/dev/dm-3 on /media/DOCUMENTS type fuseblk (rw,allow_other,blksize=4096)
/dev/dm-1 on /media/SYSTEME type fuseblk (rw,allow_other,blksize=4096)
none on /proc/sys/fs/binfmt_misc type binfmt_misc (rw)
sunrpc on /var/lib/nfs/rpc_pipefs type rpc_pipefs (rw)

[root@kwizatz ~]# cat /etc/fstab
# /etc/fstab: static file system information.
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>

tmpfs	/dev/shm	tmpfs	defaults	0	0
devpts	/dev/pts	devpts	gid=5,mode=620	0	0
sysfs	/sys	sysfs	defaults	0	0
proc	/proc	proc	defaults	0	0
/dev/dm-9	/	ext3	defaults	1	1
/dev/dm-7	/boot	ext3	defaults	1	2
/dev/dm-3	/media/DOCUMENTS	ntfs-3g	defaults,locale=fr_FR.UTF-8	0	0
/dev/dm-1	/media/SYSTEME	ntfs-fuse	defaults,umask=0,locale=fr_FR.UTF-8	0	0
Comment 1 Nicolas Chauvet (kwizart) 2009-02-26 11:11:36 EST
This problem seems to be fixed at this date

Note You need to log in before you can comment on or make changes to this bug.