Bug 481597 - kickstart prompts for root password if using autostep and encrypted root password
kickstart prompts for root password if using autostep and encrypted root pass...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: anaconda (Show other bugs)
4.6
All Linux
medium Severity medium
: rc
: ---
Assigned To: Martin Sivák
Alexander Todorov
:
Depends On: 471122
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-26 12:15 EST by Olivier Fourdan
Modified: 2013-03-03 21:47 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 471122
Environment:
Last Closed: 2009-05-18 16:16:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Adapt the RHEL5 patch to work with RHEL4 anaconda/kickstart (713 bytes, patch)
2009-01-27 10:18 EST, Martin Sivák
no flags Details | Diff

  None (edit)
Description Olivier Fourdan 2009-01-26 12:15:31 EST
+++ This bug was initially created as a clone of Bug #471122 +++

Escalated to Bugzilla from IssueTracker

--- Additional comment from tao@redhat.com on 2008-11-11 16:28:41 EDT ---

Description of problem:

Booting from a RHEL5u2 dvd with kickstart install option

When I specify the --iscrypted option to "rootpw" the installer prompts me for a root password.
It does not do this when I omit "--iscrypted" and use a plain text password.

i.e. this works:
rootpw not-encrypted
this does not:
rootpw --iscrypted $1$fLimg$fpfXaeS0pcObdbsrgsB45/

How reproducible:

Boot from a RHEL5u2 dvd with option to start kickstart installation.
In kickstart configuration file, enable encrypted password and try using encrypted password for root user.

Actual results:

Install process asks for root password and rest installation proceeds as per kickstart configuration file

Expected results:

Install process should not prompt for root password when encrypted password for root is provided in kickstart configuration file

Additional info:

* The problem only occurs when autostep is used in kickstart configuration file. Without autostep option kickstart install works fine with encrypted root password.

--- Additional comment from jbastian@redhat.com on 2008-11-12 14:36:44 EDT ---

Created an attachment (id=323379)
smaller, more efficient patch

A smaller, more efficient patch to fix the problem.
Comment 1 Alexander Todorov 2009-01-27 02:39:28 EST
qa_ack+

ks.cfg:

rootpw --is-encrypted XXXXXX
autostep
Comment 2 Martin Sivák 2009-01-27 10:18:38 EST
Created attachment 330098 [details]
Adapt the RHEL5 patch to work with RHEL4 anaconda/kickstart

When crypted password is specified, do not use the "Root password" dialog
Comment 3 RHEL Product and Program Management 2009-01-27 10:32:08 EST
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 13 Alexander Todorov 2009-02-17 04:54:25 EST
VERIFIED with anaconda-10.1.1.96-1
Comment 14 Alexander Todorov 2009-02-18 10:45:38 EST
Martin,
there's a similar problem with autostep and text mode even when using plain text root password. 

text mode with rootpw --isencrypted $value:
- anaconda stops at the welcome screen
- pressing next button goes to next screen. screen values are predefined
- root password field is empty

text mode with plain text root password:
- same as above except that rootpw field contains "*"

Do we need another bug open for the text mode case or I can safely change this to FAILS_QA. What's your preference?
Comment 15 Joel Andres Granados 2009-02-19 09:27:16 EST
If the same error occurs in text mode, the logical thing to do is to FAILS_QA.  I'll see if I can work something out.
Comment 16 Joel Andres Granados 2009-02-19 10:02:14 EST
Irc discussion with atodorov:
<snip>
<atodorov> there could be 2 issues in text mode 1) not switching through different screens and 2) not understanding --isencrypted when in autostep 
<jgranados> ok, but let me get this strait
<jgranados> the original bug, did not stop at welcome screen
<jgranados> it stopped ant root passwd screen right?
<jgranados> in gui I mean.
<atodorov> the original bug was against GUI mode. It stopped at the root password screen
<jgranados> ok, so they are different bugs
<jgranados> you are correct in verifying this one and opening a new one.
<atodorov> yes they are, but the nature of the problem is similar
<jgranados> no,  its different code.
<jgranados> gui new about the autostep.
<jgranados> text mode apparently does not.
<atodorov> is it supported in text mode ? 
<jgranados> dunno.
<jgranados> in any case it is a different issue and should be handled post 4.8
<atodorov> hmmm, ok, will open another bug
<jgranados> thx
</snip>
Comment 18 errata-xmlrpc 2009-05-18 16:16:53 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-0978.html

Note You need to log in before you can comment on or make changes to this bug.