Bug 481598 - Files not trashed to the correct location in Dolphin/Konqueror
Files not trashed to the correct location in Dolphin/Konqueror
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: kdebase-runtime (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-26 12:16 EST by John Beranek
Modified: 2009-03-17 01:41 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-16 21:32:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
KDE Software Compilation 178479 None None None Never

  None (edit)
Description John Beranek 2009-01-26 12:16:16 EST
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:

Always, if you have a "$topdir" trash directory configured

Steps to Reproduce:
1.For a particular filesystem, create an appropriately configured .Trash directory (writeable to all users of the system, generally drwxrwxrwt)
2.Delete a file from this filesystem using Dolphin or Konqueror 4
  
Actual results:

File ends up in $HOME/.local/share/Trash

Expected results:

File should end up in the .Trash directory of the filesystem you deleted the file from.

Additional info:

kdelibs-4.1.4-2.fc10.x86_64
Bug also manifests in Fedora 10.

Upstream bug report http://bugs.kde.org/show_bug.cgi?id=178479

Fixed in KDE Subversion repository, only scheduled to be included in KDE 4.2.1 according to the bug report.

Diffs:

http://websvn.kde.org/branches/KDE/4.2/kdebase/runtime/kioslave/trash/trashimpl.cpp?r1=916987&r2=916986&pathrev=916987

This causes difficulties for configurations where user home directories are on a remote (NFS) share. If people delete files from their local filesystems, they end up being copied to the remote home directory, which can fill up the user's quota, and be slow.
Comment 1 John Beranek 2009-01-26 12:18:16 EST
Any chance of this being backported to KDE 4.1.4 in F9/F10?
Comment 2 Rex Dieter 2009-01-26 12:21:55 EST
We're working on kde-4.2.0 updates now, we may be able to squeeze this in... the patch looks small, and straightforward.
Comment 3 Rex Dieter 2009-01-26 12:36:02 EST
added to rawhide, we'll pick this up for F-9/F-10 updates as well.

* Mon Jan 26 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.2.0-2
- Files not trashed to the correct location in Dolphin/Konqueror
  (#481598, kdebug#178479)
Comment 4 John Beranek 2009-01-26 15:41:29 EST
Excellent, and very speedy - thanks!
Comment 5 Fedora Update System 2009-02-04 21:26:53 EST
kdeutils-4.2.0-1.fc10, kdetoys-4.2.0-1.fc10, kdesdk-4.2.0-1.fc10, kdeplasma-addons-4.2.0-1.fc10, kdepimlibs-4.2.0-1.fc10, kdepim-4.2.0-2.fc10, kdenetwork-4.2.0-2.fc10, kdemultimedia-4.2.0-1.fc10.1, kdegraphics-4.2.0-1.fc10, kdegames-4.2.0-1.fc10, kdeedu-4.2.0-2.fc10, kdebase-runtime-4.2.0-3.fc10, kdebase-4.2.0-2.fc10, kdebindings-4.2.0-1.fc10, kdeartwork-4.2.0-1.fc10, kdeadmin-4.2.0-1.fc10.1, kdeaccessibility-4.2.0-1.fc10, soprano-2.2.1-1.fc10, strigi-0.6.3-1.fc10, akonadi-1.1.1-1.fc10, automoc-1.0-0.11.rc3.fc10, compiz-0.7.8-7.fc10, kde-settings-4.1-5.20090126svn.fc10, kde-plasma-runcommand-1.0-1.fc10, kde-plasma-quickaccess-0.7.1-7.fc10, kdebluetooth-0.3-1.fc10, kde-i18n-3.5.10-2.fc10, krazy2-2.8-7.20090127svn.fc10, phonon-4.3.0-5.fc10, kde-l10n-4.2.0-2.fc10, kdelibs-4.2.0-7.fc10, kdebase-workspace-4.2.0-4.fc10.2 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update kdeutils kdetoys kdesdk kdeplasma-addons kdepimlibs kdepim kdenetwork kdemultimedia kdegraphics kdegames kdeedu kdebase-runtime kdebase kdebindings kdeartwork kdeadmin kdeaccessibility soprano strigi akonadi automoc compiz kde-settings kde-plasma-runcommand kde-plasma-quickaccess kdebluetooth kde-i18n krazy2 phonon kde-l10n kdelibs kdebase-workspace'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-1387
Comment 6 Fedora Update System 2009-02-06 00:23:56 EST
kdeutils-4.2.0-1.fc10, kdetoys-4.2.0-1.fc10, kdesdk-4.2.0-1.fc10, kdeplasma-addons-4.2.0-1.fc10, kdepimlibs-4.2.0-1.fc10, kdepim-4.2.0-2.fc10, kdenetwork-4.2.0-2.fc10, kdemultimedia-4.2.0-1.fc10.1, kdegraphics-4.2.0-1.fc10, kdegames-4.2.0-1.fc10, kdebase-runtime-4.2.0-3.fc10, kdebase-4.2.0-2.fc10, kdebindings-4.2.0-1.fc10, kdeartwork-4.2.0-1.fc10, kdeadmin-4.2.0-1.fc10.1, kdeaccessibility-4.2.0-1.fc10, soprano-2.2.1-1.fc10, strigi-0.6.3-1.fc10, akonadi-1.1.1-1.fc10, automoc-1.0-0.11.rc3.fc10, compiz-0.7.8-7.fc10, kde-settings-4.1-5.20090126svn.fc10, kde-plasma-runcommand-1.0-1.fc10, kde-plasma-quickaccess-0.7.1-7.fc10, kdebluetooth-0.3-1.fc10, kde-i18n-3.5.10-2.fc10, krazy2-2.8-7.20090127svn.fc10, phonon-4.3.0-5.fc10, kdelibs-4.2.0-9.fc10, kdeedu-4.2.0-5.fc10, kde-l10n-4.2.0-2.fc10, kdebase-workspace-4.2.0-4.fc10.2 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update kdeutils kdetoys kdesdk kdeplasma-addons kdepimlibs kdepim kdenetwork kdemultimedia kdegraphics kdegames kdebase-runtime kdebase kdebindings kdeartwork kdeadmin kdeaccessibility soprano strigi akonadi automoc compiz kde-settings kde-plasma-runcommand kde-plasma-quickaccess kdebluetooth kde-i18n krazy2 phonon kdelibs kdeedu kde-l10n kdebase-workspace'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-1387
Comment 7 John Beranek 2009-02-07 16:26:51 EST
Not working here, deleted a file in /tmp and it didn't end up in my /.Trash but instead in my NFS mounted home directory.

# rpm -qa|grep kdebase
kdebase-runtime-4.2.0-3.fc10.x86_64
kdebase3-pim-ioslaves-3.5.10-4.fc10.x86_64
kdebase-workspace-libs-4.2.0-4.fc10.2.x86_64
kdebase3-libs-3.5.10-4.fc10.x86_64
kdebase-libs-4.2.0-2.fc10.x86_64
kdebase-workspace-4.2.0-4.fc10.2.x86_64
kdebase-4.2.0-2.fc10.x86_64
kdebase3-3.5.10-4.fc10.x86_64
kdebase-runtime-libs-4.2.0-3.fc10.x86_64

# ls -la /.Trash/
total 16
drwxrwxrwt  3 root     root     4096 2008-07-09 10:55 .
drwxr-xr-x 32 root     root     4096 2009-02-02 08:40 ..
drwx------  4 beranej1 beranej1 4096 2008-07-09 10:55 20158
Comment 8 John Beranek 2009-02-07 16:29:48 EST
Just to clarify, it doesn't work in either Konqueror or Dolphin.
Comment 9 Kevin Kofler 2009-02-07 16:47:15 EST
No surprise there, they're both using the DolphinPart internally.
Reopening...
Comment 10 Fedora Update System 2009-02-07 17:20:48 EST
kdeutils-4.2.0-1.fc10, kdetoys-4.2.0-1.fc10, kdesdk-4.2.0-1.fc10, kdeplasma-addons-4.2.0-1.fc10, kdepimlibs-4.2.0-1.fc10, kdepim-4.2.0-2.fc10, kdenetwork-4.2.0-2.fc10, kdemultimedia-4.2.0-1.fc10.1, kdegraphics-4.2.0-1.fc10, kdegames-4.2.0-1.fc10, kdebase-runtime-4.2.0-3.fc10, kdebase-4.2.0-2.fc10, kdebindings-4.2.0-1.fc10, kdeartwork-4.2.0-1.fc10, kdeadmin-4.2.0-1.fc10.1, kdeaccessibility-4.2.0-1.fc10, soprano-2.2.1-1.fc10, strigi-0.6.3-1.fc10, akonadi-1.1.1-1.fc10, automoc-1.0-0.11.rc3.fc10, compiz-0.7.8-7.fc10, kde-plasma-runcommand-1.0-1.fc10, kde-plasma-quickaccess-0.7.1-7.fc10, kdebluetooth-0.3-1.fc10, kde-i18n-3.5.10-2.fc10, krazy2-2.8-7.20090127svn.fc10, kde-settings-4.1-6.20090206svn.fc10, phonon-4.3.0-5.fc10, kdelibs-4.2.0-9.fc10, kdeedu-4.2.0-5.fc10, kde-l10n-4.2.0-2.fc10, kdebase-workspace-4.2.0-4.fc10.2 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update kdeutils kdetoys kdesdk kdeplasma-addons kdepimlibs kdepim kdenetwork kdemultimedia kdegraphics kdegames kdebase-runtime kdebase kdebindings kdeartwork kdeadmin kdeaccessibility soprano strigi akonadi automoc compiz kde-plasma-runcommand kde-plasma-quickaccess kdebluetooth kde-i18n krazy2 kde-settings phonon kdelibs kdeedu kde-l10n kdebase-workspace'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-1387
Comment 11 Rex Dieter 2009-02-09 13:02:58 EST
Re comment #7 , John, please provide feedback in the upstream bug about your continuing issue(s), http://bugs.kde.org/show_bug.cgi?id=178479
Comment 12 John Beranek 2009-02-09 16:02:28 EST
Done. http://bugs.kde.org/show_bug.cgi?id=178479#c15
Comment 13 John Beranek 2009-02-09 17:05:40 EST
OK, so further reading of http://bugs.kde.org/show_bug.cgi?id=178479 shows my particular problem is actually caused by HAL not having information for LVM volumes.

I can verify this, the output of 'hal-device' doesn't mention my LVM root partition.

Not sure if that means that this bug should be closed or not.
Comment 14 Steven M. Parrish 2009-03-16 21:32:58 EDT
since it is not an issue with kdebase-runtime going to close this as upstream has closed it as well
Comment 15 Kevin Kofler 2009-03-17 01:41:46 EDT
Well, strictly speaking the issue is that KMountPoint (and Solid in general) does not support DeviceKit yet. DeviceKit supports LVM unlike HAL. But that's not really a bug, it's a Solid backend waiting to be written, and it'd only be usable on F11 and above anyway.

Note You need to log in before you can comment on or make changes to this bug.