Bug 481620 - libext2fs info file inaccessible
libext2fs info file inaccessible
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: e2fsprogs (Show other bugs)
10
All Linux
low Severity low
: ---
: ---
Assigned To: Eric Sandeen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-26 14:06 EST by Jerry James
Modified: 2009-02-25 11:24 EST (History)
3 users (show)

See Also:
Fixed In Version: 1.41.4-1.fc10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-25 11:24:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jerry James 2009-01-26 14:06:15 EST
Description of problem:
Running "info libext2fs" results in "Unable to find node referenced by `libext2fs' in `(dir)Top'." and the main info page.  From there, I can see the info page in the menu.  Manually selecting it with 'm' results in the complaint "libext2fs.  info: No such file or directory".

Version-Release number of selected component (if applicable):
e2fsprogs-devel-1.41.3-2.fc10.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Run "info libext2fs"
  
Actual results:
The info page is not shown.

Expected results:
The info page should be shown.

Additional info:
The problem is that makeinfo 4.12 interprets the dot in "libext2fs.info" to be the end of the description portion of the info entry, even though it hasn't seen the closing parenthesis yet.  Making the reference be to just "libext2fs" works.
Comment 1 Eric Sandeen 2009-01-26 22:15:17 EST
Ok, so "info libext2fs.info" works, "info libext2fs" fails.

Sorry, I'm no info-guru, so not sure what you mean by "Making the reference to be just "libext2fs" - where is this?

What's the proposed solution?

Ahah, maybe here...

@direntry
* libext2fs: (libext2fs.info).                  The EXT2FS library.
@end direntry

should change to....

@direntry
* libext2fs: (libext2fs).                  The EXT2FS library.
@end direntry

Is that right?

Thanks,
-Eric
Comment 2 Jerry James 2009-01-27 11:31:34 EST
Yes, that is what I meant.  Sorry to be obscure.
Comment 3 Eric Sandeen 2009-01-27 11:33:47 EST
No problem, sorry I was dense.  :)  Do you know offhand if older versions of makeinfo will still be happy with this change?

Thanks,
-Eric
Comment 4 Jerry James 2009-01-27 11:55:32 EST
Yes, it has supported both forms for a long time.  I'm not sure why the .info form is broken now.  I suspect it's a bug, but haven't dug into it.  In any case, the /usr/share/info/dir file on my system consists almost entirely of the no-".info" form, so it must be working for a lot of packages.
Comment 5 Eric Sandeen 2009-01-29 17:48:48 EST
I've committed this change to rawhide, and sent a patch upstream.  It'll get to F10 at some point :)

Thanks for the report,
-Eric
Comment 6 Eric Sandeen 2009-02-04 10:49:52 EST
Committed to e2fsprogs-1.41.4-1.fc10, should hit the F10 testing repo soon.

Thanks,
-Eric
Comment 7 Fedora Update System 2009-02-04 21:09:59 EST
e2fsprogs-1.41.4-1.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update e2fsprogs'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-1224
Comment 8 Fedora Update System 2009-02-25 11:24:07 EST
e2fsprogs-1.41.4-1.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.