Bug 481632 - radvd relies on deprecated initscripts setting
radvd relies on deprecated initscripts setting
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: radvd (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Jiri Skala
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-26 15:17 EST by Pierre Ossman
Modified: 2014-11-09 17:31 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-02 08:38:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pierre Ossman 2009-01-26 15:17:36 EST
From /etc/init.d/radvd:

        # Check that networking is up.  
        [ "${NETWORKING_IPV6}" = "yes" ] || exit 1


From /usr/share/doc/initscripts-8.86/sysconfig.txt:

  obsoleted values from earlier releases:

...

    NETWORKING_IPV6=yes|no
      Enable or disable global IPv6 initialization


I hope the problem is obvious. :)
Comment 1 Jiri Skala 2009-01-27 11:55:41 EST
The init script is not POSIX compliant. I'll change it to be POSIX compliant.
Comment 2 Fedora Update System 2009-03-25 07:42:17 EDT
radvd-1.1-6.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/radvd-1.1-6.fc10
Comment 3 Fedora Update System 2009-04-27 17:36:44 EDT
radvd-1.1-6.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.