Bug 481650 - makewhat fails if /usr is read-only
makewhat fails if /usr is read-only
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: man (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Ivana Varekova
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-26 15:27 EST by Bruce Jerrick
Modified: 2009-02-12 09:08 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-12 09:08:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bruce Jerrick 2009-01-26 15:27:55 EST
Description of problem:
/usr/sbin/makewhatis skips man directories if they're read-only, because it
  thinks the 'whatis' database files go there.  In reality, the database is
  /var/cache/man/whatis .

Version-Release number of selected component (if applicable):
man-1.6f-11.fc10

How reproducible:
Always

Steps to Reproduce:
1. [Re-]mount /usr read-only
2. Run 'makewhatis -w -v'
  
Actual results:
Messages for virtually all man page directories, such as:
  skipping /usr/share/man - directory is readonly 
and the database file is not rebuilt.

Expected results:
Silence, with a new database file.

Additional info:
Comment 1 Bruce Jerrick 2009-01-30 15:24:20 EST
The fix is simple -- the entire 'if' statement following this comment
can be removed (it's completely superfluous; the 'whatis' files are no
longer in the man dirs):

    # if $mandir is on a readonly partition, and the whatis file
    # is not a symlink, then let's skip trying to update it
    if ...
    ...
    fi

This is a better description of what a user sees:
On a freshly installed system (with no /var/cache/man/whatis
database yet):

    % man -k man
    man: nothing appropriate

If /usr is read-only, after running 'makewhatis', the same thing happens.
Comment 2 Ivana Varekova 2009-02-12 09:08:14 EST
Thanks. Fixed in man-1.6f-16.fc11.

Note You need to log in before you can comment on or make changes to this bug.