Bug 481651 - espeak can't output sound properly
espeak can't output sound properly
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: espeak (Show other bugs)
10
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Francois Aucamp
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-26 15:42 EST by Jason Woofenden
Modified: 2009-07-16 14:55 EDT (History)
3 users (show)

See Also:
Fixed In Version: 1.40.02-2.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-11 12:56:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jason Woofenden 2009-01-26 15:42:04 EST
Description of problem:

I do: espeak "testing testing 1 2 3"

and just hear a quick noise like "brk" and then espeak exits. If I tell it to speak a lot of text, I get more noise, but it is unintelligible. Very occasionally I hear a snippet of a word.

Version-Release number of selected component (if applicable):

espeak-1.39-1.fc10 (i386)

How reproducible:

always

Steps to Reproduce:
1. install fedora 10, run all updates System -> Administration -> Update System
2. install espeak  from System -> Administration -> Add/Remove Software
3. run this in the terminal twice: espeak "testing testing 1 2 3"
  
Actual results:

quick "brk" noise, then espeak exits

Expected results:

intelligable synthesized speech

Additional info:

I also tried running espeak under padsp like so:

padsp espeak "testing testing 1 2 3"

but got the same results.

I also tried putting myself in the groups "pulse-rt" and "jackuser" and rebooting. That didn't seem to make any difference either.

espeak was capable of making perfectly good .wav files with the -w option.


espeak can be compiled to use either portaudio or pulseaudio. Currently the rpm is built with portaudio, which does not seem to be well supported by fedora. My suggestion is to compile espeak with pulseaudio support instead. To do this I think all you'd have to do is edit the Makefile to select pulseaudio instead of portaudio, and change the .spec file to build-depend on pulseaudio-libs-devel instead of portaudio-devel
Comment 1 Fedora Update System 2009-06-30 08:30:59 EDT
espeak-1.40.02-2.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/espeak-1.40.02-2.fc11
Comment 2 Fedora Update System 2009-06-30 08:31:08 EDT
espeak-1.40.02-2.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/espeak-1.40.02-2.fc10
Comment 3 Fedora Update System 2009-07-02 01:45:00 EDT
espeak-1.40.02-2.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update espeak'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-7205
Comment 4 Fedora Update System 2009-07-02 01:50:13 EDT
espeak-1.40.02-2.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update espeak'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-7250
Comment 5 Kevin Kofler 2009-07-05 18:17:17 EDT
While native PulseAudio support is clearly the best solution, I don't understand why PortAudio is not working for you. I did the PortAudio patch to support PulseAudio's ALSA plugin and espeak was one of the 2 main apps I used for testing (the other one was Audacity with its builtin fork of PortAudio), it always worked fine for me.
Comment 6 Francois Aucamp 2009-07-06 02:53:49 EDT
(In reply to comment #5)

Thanks, Kevin - PortAudio also works fine for me. However, another espeak bug with similar symptoms has since appeared (#506624), and the reporter confirms that converting to native PulseAudio solved it.
Comment 7 Fedora Update System 2009-07-11 12:56:46 EDT
espeak-1.40.02-2.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 8 Fedora Update System 2009-07-11 13:31:39 EDT
espeak-1.40.02-2.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 9 Ilya Ryabinkin 2009-07-15 16:15:56 EDT
espeak-1.40.02-2.fc10 causes stardict to hung. Fall back to espeak-1.39-1.fc10.i386 resolves this issue.

espeak command
     espeak "Hello" 
does not produce any sounds and espeak itself does not finish. Ctrl-D does not work either, only ctrl-C.

OS -- Fedora 10 without pulseaudio (actually, only pulseaudio-libs-0.9.14-3.fc10.i386 presents)
Comment 10 Francois Aucamp 2009-07-16 03:14:23 EDT
(In reply to comment #9)

Thanks for the report - I'll have to install F10 on a local machine and strip out pulseaudio in order to debug this, so it might take a little while. Would you mind opening a new bug report for this, since it's a newly-introduced issue caused by solving the original bug? (and so that I don't forget about it ;)
Comment 11 Kevin Kofler 2009-07-16 14:55:44 EDT
Re comment #9, I'm afraid it's just working as designed: as espeak is built to use PulseAudio directly, it simply cannot work without PulseAudio anymore.

Upstream needs to support building with both PulseAudio and PortAudio and fallback to PortAudio if PulseAudio is not detected if they want this to work. Otherwise, PulseAudio is simply required from now on. There's nothing the packager can do about this.

Note You need to log in before you can comment on or make changes to this bug.