Bug 481678 - kernel crash on bluetooth
kernel crash on bluetooth
Status: CLOSED DUPLICATE of bug 488115
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-26 19:09 EST by Lukas Bezdicka
Modified: 2009-03-02 21:27 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-02 21:27:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/var/log/messages output (123.03 KB, text/plain)
2009-01-26 19:09 EST, Lukas Bezdicka
no flags Details

  None (edit)
Description Lukas Bezdicka 2009-01-26 19:09:15 EST
Created attachment 330047 [details]
/var/log/messages output

Description of problem:
Kernel seems to be randomly crasing when trying to connect to bluetooth device or trying to create network over bluetooth

How reproducible:
Seems to be easy to reproduce just requires time

Steps to Reproduce:
1. get a bluetooth device (in this case openmoko)
2. try to connect to it trough bluetooth using various ways like bluetooth networking pand etc...
3. get a vmcore from kdump
  
Actual results:
please wait... (determining panic task)         
bt: cannot transition from IRQ stack to current process stack:
        IRQ stack pointer: ffff88007e61f9c0
    process stack pointer: ffffffff81011e13
       current stack base: ffff88007e61a000
      KERNEL: /usr/lib/debug/lib/modules/2.6.29-0.48.rc2.git1.fc11.x86_64/vmlinux
    DUMPFILE: 127.0.0.1-2009-01-26-20:57:58/vmcore
        CPUS: 2
        DATE: Mon Jan 26 20:57:55 2009
      UPTIME: 00:34:55
LOAD AVERAGE: 2.30, 2.21, 2.18
       TASKS: 265
    NODENAME: AetheR
     RELEASE: 2.6.29-0.48.rc2.git1.fc11.x86_64
     VERSION: #1 SMP Fri Jan 23 15:33:29 EST 2009
     MACHINE: x86_64  (1596 Mhz)
      MEMORY: 2 GB
       PANIC: ""
         PID: 0
     COMMAND: "swapper"
        TASK: ffff88007e6146a0  (1 of 2)  [THREAD_INFO: ffff88007e61a000]
         CPU: 1
       STATE: TASK_RUNNING (PANIC)

crash> where
No stack.
crash> bt
PID: 0      TASK: ffff88007e6146a0  CPU: 1   COMMAND: "swapper"
 #0 [ffff88007e61f9c0] machine_kexec at ffffffff81026128
 #1 [ffff88007e61faf0] crash_kexec at ffffffff8107e632
 #2 [ffff88007e61fbd0] oops_end at ffffffff81385374
 #3 [ffff88007e61fc00] die at ffffffff81014a31
 #4 [ffff88007e61fc30] do_general_protection at ffffffff81384feb
 #5 [ffff88007e61fc60] general_protection at ffffffff813846e5
 #6 [ffff88007e61fce8] skb_dequeue at ffffffff812e0e4d
 #7 [ffff88007e61fd40] skb_queue_purge at ffffffff812e17b0
 #8 [ffff88007e61fd60] hci_conn_del at ffffffffa02875bd
 #9 [ffff88007e61fd90] hci_event_packet at ffffffffa028829f
#10 [ffff88007e61fe70] hci_rx_task at ffffffffa0286226
#11 [ffff88007e61fed0] tasklet_action at ffffffff8104f326
#12 [ffff88007e61ff00] __do_softirq at ffffffff8104fa8d
#13 [ffff88007e61ff40] call_softirq at ffffffff8101272c
#14 [ffff88007e61ff58] do_softirq at ffffffff81013849
#15 [ffff88007e61ff78] irq_exit at ffffffff8104f6db
#16 [ffff88007e61ff88] do_IRQ at ffffffff81013b60
--- <IRQ stack> ---
bt: cannot transition from IRQ stack to current process stack:
        IRQ stack pointer: ffff88007e61f9c0
    process stack pointer: ffffffff81011e13
       current stack base: ffff88007e61a000
crash> in
info              inspect           interpreter-exec  interrupt         
crash> in
info              inspect           interpreter-exec  interrupt         
crash> interrupt 
interrupt = $8 = -2130634240
crash> irq
irq: x86_64_dump_irq: irq_desc[] does not exist?
crash> bt full
bt: invalid task or pid value: full
crash> inspect
$9 = -2130634240



Expected results:
dunno probably connection with bluetooth device
Comment 1 James 2009-02-01 12:30:04 EST
I see this with kernel-2.6.29-0.74.rc3.git3.fc11.x86_64. It happens immediately after adding a new device via the GNOME BlueTooth applet's "Setup new device" wizard.
Comment 2 James 2009-02-01 18:40:07 EST
Another note: the i686 version of the same kernel doesn't seem to have a problem, at least for the USB dongle and phone I tested. Either way, I think this bug's severity should be changed to High as it takes down the whole system.
Comment 3 James 2009-02-17 04:40:10 EST
I've not seen this in kernel-2.6.29-0.33.rc5.fc10.x86_64 so far.
Comment 4 Chuck Ebbert 2009-03-02 21:27:06 EST

*** This bug has been marked as a duplicate of bug 488115 ***

Note You need to log in before you can comment on or make changes to this bug.