Bug 481741 - Oops in cdc-wdm when connecting phone: Sony Ericsson W350
Oops in cdc-wdm when connecting phone: Sony Ericsson W350
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
9
i386 Linux
low Severity low
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-27 08:19 EST by Heishiro Mitsurugi
Modified: 2009-05-18 22:04 EDT (History)
5 users (show)

See Also:
Fixed In Version: 2.6.27.23-78.2.50.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-18 22:04:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Linux Kernel 12332 None None None Never

  None (edit)
Description Heishiro Mitsurugi 2009-01-27 08:19:07 EST
Description of problem:

When i connect a Sony Ericcson W350 phone to the PC, and select the File Transfer Mode in the phone, there's no communication between the phone and the PC.

I'm reporting a bug, because i tried executing the dmesg program and i saw the following message:

usb 3-1: new full speed USB device using uhci_hcd and address 2                    
usb 3-1: configuration #2 chosen from 1 choice                                     
usb 3-1: New USB device found, idVendor=0fce, idProduct=d0d0                       
usb 3-1: New USB device strings: Mfr=1, Product=2, SerialNumber=3                  
usb 3-1: Product: Sony Ericsson W350                                               
usb 3-1: Manufacturer: Sony Ericsson                                               
usb 3-1: SerialNumber: 3543880262642500                                            
cdc_acm 3-1:2.1: ttyACM0: USB ACM device                                           
usbcore: registered new interface driver cdc_acm                                   
cdc_acm: v0.26:USB Abstract Control Model driver for USB modems and ISDN adapters  
BUG: unable to handle kernel NULL pointer dereference at 00000003                  
IP: [<f909cab5>] :cdc_wdm:wdm_probe+0x12a/0x375                                    
*pde = 49e04067                                                                    
Oops: 0000 [#1] SMP                                                                
Modules linked in: cdc_wdm(+) cdc_acm bridge stp bnep rfcomm l2cap bluetooth vboxnetflt vboxdrv w83627hf hwmon_vid hwmon nls_utf8 cifs fuse sunrpc cpufreq_ondemand acpi_cpufreq loop dm_multipath scsi_dh ipv6 snd_emu10k1_synth snd_emux_synth snd_seq_virmidi snd_seq_midi_emul snd_emu10k1 snd_rawmidi snd_ac97_codec ac97_bus snd_seq_dummy snd_seq_oss snd_seq_midi_event snd_seq bttv snd_pcm_oss snd_mixer_oss snd_pcm videodev v4l1_compat snd_seq_device snd_timer ir_common compat_ioctl32 i2c_algo_bit v4l2_common snd_page_alloc nvidia(P) iTCO_wdt iTCO_vendor_support snd_util_mem videobuf_dma_sg ppdev emu10k1_gp parport_pc videobuf_core btcx_risc snd_hwdep i2c_i801 parport gameport tveeprom snd soundcore sr_mod e1000e i2c_core pcspkr cdrom floppy sg dm_snapshot dm_zero dm_mirror dm_log dm_mod ata_generic ata_piix pata_acpi libata sd_mod scsi_mod crc_t10dif ext3 jbd mbcache uhci_hcd ohci_hcd ehci_hcd [last unloaded: microcode]

Pid: 5177, comm: modprobe Tainted: P   M    W (2.6.27.9-73.fc9.i686 #1)
EIP: 0060:[<f909cab5>] EFLAGS: 00010286 CPU: 1
EIP is at wdm_probe+0x12a/0x375 [cdc_wdm]
EAX: 00000000 EBX: f042c16c ECX: f909f180 EDX: e641e600
ESI: f042c3c0 EDI: fffffff4 EBP: f042ae74 ESP: f042ae4c
 DS: 007b ES: 007b FS: 00d8 GS: 0033 SS: 0068
Process modprobe (pid: 5177, ti=f042a000 task=e669a610 task.ti=f042a000)
Stack: f909dfd4 f0426400 f042ae6c e641e600 00000000 0800e600 f042645c e641e600
       00000000 f909dfd4 f042ae94 c059145c e641e61c f909df4c f0426400 e641e61c
       00000000 f909df80 f042aea8 c057cf50 e641e61c e641e6d8 f909df80 f042aebc
Call Trace:
 [<c059145c>] ? usb_probe_interface+0xe9/0x11c
 [<c057cf50>] ? driver_probe_device+0xa0/0x136
 [<c057d020>] ? __driver_attach+0x3a/0x59
 [<c057c977>] ? bus_for_each_dev+0x3b/0x63
 [<c057cdf5>] ? driver_attach+0x14/0x16
 [<c057cfe6>] ? __driver_attach+0x0/0x59
 [<c057c3eb>] ? bus_add_driver+0x9d/0x1ba
 [<c057d1a7>] ? driver_register+0x81/0xe1
 [<c059163e>] ? usb_register_driver+0x66/0xc0
 [<f8cfc017>] ? wdm_init+0x17/0x19 [cdc_wdm]
 [<c0401125>] ? _stext+0x3d/0x115
 [<f8cfc000>] ? wdm_init+0x0/0x19 [cdc_wdm]
 [<c0424cd4>] ? try_to_wake_up+0x227/0x232
 [<c044b3b8>] ? sys_init_module+0x87/0x178
 [<c0403cca>] ? syscall_call+0x7/0xb
 =======================
Code: 00 00 00 c7 86 9c 00 00 00 b1 ce 09 f9 66 89 46 38 8d 86 94 00 00 00 89 86 94 00 00 00 89 86 98 00 00 00 8b 02 8b 40 0c 89 45 e8 <0f> b6 40 03 83 e0 03 83 f8 03 0f 85 ff 01 00 00 8b 4d e8 80 79
EIP: [<f909cab5>] wdm_probe+0x12a/0x375 [cdc_wdm] SS:ESP 0068:f042ae4c
---[ end trace b0cbd105c408ea7a ]---
usb 3-1: USB disconnect, address 2

Version-Release number of selected component (if applicable):

Linux bbpc.local 2.6.27.9-73.fc9.i686 #1 SMP Tue Dec 16 15:25:05 EST 2008 i686 i686 i386 GNU/Linux

How reproducible:

Just plug the phone in

Steps to Reproduce:
1. Plug the phone in
2. get into a terminal
3. execute dmesg
  
Actual results:

Shows the error described previously

Expected results:

I guess it should recognize the phone, and i also guess it should mount the phone memory as a drive. Maybe not the second part, but it should recognize and mount a module or something.

Additional info:

None.
Comment 1 Thomas Kordelle 2009-02-02 05:35:50 EST
Hi,

the BUG still exists in latetest kernel (2.6.27.12-170.2.5.fc10.x86_64). I have nothing to select on the phone to trigger the BUG. Only connect the phone via USB and Oops happens.


usb 1-6.2: new full speed USB device using ehci_hcd and address 4
usb 1-6.2: configuration #2 chosen from 1 choice
usb 1-6.2: New USB device found, idVendor=0fce, idProduct=d0b5
usb 1-6.2: New USB device strings: Mfr=1, Product=2, SerialNumber=3
usb 1-6.2: Product: Sony Ericsson W380
usb 1-6.2: Manufacturer: Sony Ericsson
usb 1-6.2: SerialNumber: xxxxxxxxxxxxxxxxxx
cdc_acm 1-6.2:2.1: ttyACM0: USB ACM device
usbcore: registered new interface driver cdc_acm
cdc_acm: v0.26:USB Abstract Control Model driver for USB modems and ISDN adapters
BUG: unable to handle kernel NULL pointer dereference at 0000000000000003
IP: [<ffffffffa0b22cd4>] wdm_probe+0x155/0x3da [cdc_wdm]
PGD 61441067 PUD 635b6067 PMD 0 
Oops: 0000 [1] SMP 
CPU 1 
Modules linked in: cdc_wdm(+) cdc_acm vmnet parport_pc vmblock vmci vmmon sco bridge stp bnep l2cap bluetooth coretemp smsc47b397 hwmon nls_utf8 cifs nfs lockd nfs_acl fuse sunrpc ip6t_REJECT nf_conntrack_ipv6 ip6table_filter ip6_tables ipv6 cpufreq_ondemand acpi_cpufreq freq_table dm_multipath uinput snd_hda_intel nvidia(P) snd_seq_dummy snd_seq_oss snd_seq_midi_event snd_seq snd_seq_device snd_pcm_oss snd_mixer_oss snd_pcm snd_timer tg3 i82975x_edac iTCO_wdt snd_page_alloc iTCO_vendor_support snd_hwdep ppdev floppy edac_core libphy snd i2c_core serio_raw soundcore wmi pcspkr parport [last unloaded: vmci]
Pid: 8652, comm: modprobe Tainted: P          2.6.27.12-170.2.5.fc10.x86_64 #1
RIP: 0010:[<ffffffffa0b22cd4>]  [<ffffffffa0b22cd4>] wdm_probe+0x155/0x3da [cdc_wdm]
RSP: 0018:ffff8800635f9cd8  EFLAGS: 00010286
RAX: ffff8800634ff988 RBX: ffff880081877400 RCX: 0000000000000000
RDX: ffffffffa0b26980 RSI: ffffffffa0b23560 RDI: ffff8800818774d8
RBP: ffff8800635f9d08 R08: 0000000000000000 R09: ffff8800635f9b98
R10: ffff88012b96ae68 R11: 00000200635f9ca8 R12: 0000000000000000
R13: 0000000000000000 R14: ffff8800a4492400 R15: 0000000000000800
FS:  00007f51e5fd96f0(0000) GS:ffff88012fc04980(0000) knlGS:0000000000000000
CS:  0010 DS: 0000 ES: 0000 CR0: 000000008005003b
CR2: 0000000000000003 CR3: 0000000061432000 CR4: 00000000000006e0
DR0: 0000000000000000 DR1: 0000000000000000 DR2: 0000000000000000
DR3: 0000000000000000 DR6: 00000000ffff0ff0 DR7: 0000000000000400
Process modprobe (pid: 8652, threadinfo ffff8800635f8000, task ffff8800635adc40)
Stack:  ffff880112ce7888 ffff8800a4492430 0000000000000000 ffffffffa0b24750
 ffff8800a4492400 ffff880112ce7800 ffff8800635f9d58 ffffffff812405bd
 ffff8800635f9d28 ffffffffa0b24630 ffffffffa0b24698 ffff8800a4492430
Call Trace:
 [<ffffffff812405bd>] usb_probe_interface+0x10e/0x14b
 [<ffffffff811f508c>] driver_probe_device+0xc0/0x16e
 [<ffffffff811f5189>] __driver_attach+0x4f/0x79
 [<ffffffff811f513a>] ? __driver_attach+0x0/0x79
 [<ffffffff811f491f>] bus_for_each_dev+0x4f/0x89
 [<ffffffff811f4ed7>] driver_attach+0x1c/0x1e
 [<ffffffff811f423f>] bus_add_driver+0xb7/0x201
 [<ffffffff811f5378>] driver_register+0xa8/0x128
 [<ffffffff81240807>] usb_register_driver+0x80/0xe4
 [<ffffffffa0028000>] ? wdm_init+0x0/0x20 [cdc_wdm]
 [<ffffffffa002801e>] wdm_init+0x1e/0x20 [cdc_wdm]
 [<ffffffff8100a047>] do_one_initcall+0x47/0x12e
 [<ffffffff81065ef1>] sys_init_module+0xa9/0x1b6
 [<ffffffff8101024a>] system_call_fastpath+0x16/0x1b


Code: 48 c7 83 08 01 00 00 48 31 b2 a0 66 89 43 68 48 8d 83 f8 00 00 00 48 89 83 f8 00 00 00 48 89 83 00 01 00 00 49 8b 06 4c 8b 60 10 <41> 0f b6 44 24 03 83 e0 03 83 f8 03 0f 85 2a 02 00 00 41 80 7c 
RIP  [<ffffffffa0b22cd4>] wdm_probe+0x155/0x3da [cdc_wdm]
 RSP <ffff8800635f9cd8>
CR2: 0000000000000003
---[ end trace 1e864913aa040dfc ]---

see also: http://bugzilla.kernel.org/show_bug.cgi?id=12332
Comment 2 Heishiro Mitsurugi 2009-02-02 06:37:47 EST
Yes, it happens as soon as the phone is plugged in.

Another thing that happens is that if i connect a USB pendrive to the USB port AFTER the oops, Fedora won't recognize the pendrive at all. No message in dmesg at all. It seems that the USB port stops functioning after the phone is plugged in.
Comment 3 Chuck Ebbert 2009-02-27 03:17:30 EST
oops is at drivers/usb/class/cdc-wdm.c:644:

        iface = &intf->altsetting[0];
        ep = &iface->endpoint[0].desc;
        if (!usb_endpoint_is_int_in(ep)) {       <==== ep is NULL
                rv = -EINVAL;
                goto err;
        }
Comment 4 Chuck Ebbert 2009-03-03 18:32:07 EST
Can someone reproduce this on a 2.6.29 kernel?

There are 2.6.29-rc6 kernels for f10 in koji:
http://koji.fedoraproject.org/koji/buildinfo?buildID=83870
Comment 5 Thomas Kordelle 2009-03-04 06:51:50 EST
Hi,

kernel Linux 2.6.29-0.43.rc6.fc10.x86_64 #1 SMP Mon Feb 23 11:46:38 EST 2009 x86_64 x86_64 x86_64 GNU/Linux does not fix the BUG.

usb 1-6.2: new full speed USB device using ehci_hcd and address 4
usb 1-6.2: New USB device found, idVendor=0fce, idProduct=d0b5
usb 1-6.2: New USB device strings: Mfr=1, Product=2, SerialNumber=3
usb 1-6.2: Product: Sony Ericsson W380
usb 1-6.2: Manufacturer: Sony Ericsson
usb 1-6.2: SerialNumber: xxxxxxxxxxxxxx
usb 1-6.2: configuration #2 chosen from 1 choice
BUG: unable to handle kernel NULL pointer dereference at 0000000000000003
IP: [<ffffffffa0308d00>] wdm_probe+0x1a0/0x424 [cdc_wdm]
PGD 127161067 PUD 12d436067 PMD 0
Oops: 0000 [#1] SMP
last sysfs file: /sys/devices/pci0000:00/0000:00:1d.7/usb1/1-6/1-6.2/1-6.2:2.2/bInterfaceClass
CPU 1
Modules linked in: cdc_wdm(+) sco bridge stp bnep l2cap bluetooth coretemp smsc47b397 hwmon nls_utf8 cifs nfs lockd nfs_acl auth_rpcgss sunrpc ip6t_REJECT nf_conntrack_ipv6 ip6table_filter ip6_tables ipv6 cpufreq_ondemand acpi_cpufreq freq_table dm_multipath uinput snd_hda_codec_realtek snd_hda_intel snd_hda_codec snd_hwdep snd_seq_dummy snd_seq_oss snd_seq_midi_event snd_seq snd_seq_device snd_pcm_oss snd_mixer_oss ppdev snd_pcm iTCO_wdt floppy iTCO_vendor_support parport_pc snd_timer serio_raw snd pcspkr parport wmi soundcore i82975x_edac tg3 edac_core snd_page_alloc [last unloaded: microcode]
Pid: 2856, comm: modprobe Not tainted 2.6.29-0.43.rc6.fc10.x86_64 #1 HP xw4400 Workstation
RIP: 0010:[<ffffffffa0308d00>]  [<ffffffffa0308d00>] wdm_probe+0x1a0/0x424 [cdc_wdm]
RSP: 0018:ffff88012715bcc8  EFLAGS: 00010286
RAX: ffff88012d95f648 RBX: ffff88012cc6ae00 RCX: 0000000000000000
RDX: ffffffffa030a9f0 RSI: ffffffffa0309606 RDI: ffff88012cc6aed8
RBP: ffff88012715bd18 R08: 0000000000000000 R09: ffffffff8126b964
R10: ffff88012fa3c000 R11: 00000000ffffffff R12: 0000000000000000
R13: ffff88012d9de46c R14: ffff880128885400 R15: 0000000000000000
FS:  00007f18018136f0(0000) GS:ffff88012e9de280(0000) knlGS:0000000000000000
CS:  0010 DS: 0000 ES: 0000 CR0: 000000008005003b
CR2: 0000000000000003 CR3: 000000012715e000 CR4: 00000000000006e0
DR0: 0000000000000000 DR1: 0000000000000000 DR2: 0000000000000000
DR3: 0000000000000000 DR6: 00000000ffff0ff0 DR7: 0000000000000400
Process modprobe (pid: 2856, threadinfo ffff88012715a000, task ffff8801271096f0)
Stack:
 ffffffff8126b964 ffff880128885430 080088012715bd08 ffff88012701b088
 ffff880128885500 ffff880128885430 0000000000000000 ffffffffa030a7c0
 ffff880128885400 ffff88012701b000 ffff88012715bd68 ffffffff8126c9ae
Call Trace:
 [<ffffffff8126b964>] ? usb_match_one_id+0x2b/0x88
 [<ffffffff8126c9ae>] usb_probe_interface+0x112/0x166
 [<ffffffff8121d194>] driver_probe_device+0xc4/0x172
 [<ffffffff8121d2a4>] __driver_attach+0x62/0x8c
 [<ffffffff8121d242>] ? __driver_attach+0x0/0x8c
 [<ffffffff8121ca48>] bus_for_each_dev+0x4c/0x83
 [<ffffffff8121cfdb>] driver_attach+0x1c/0x1e
 [<ffffffff8121c375>] bus_add_driver+0xb7/0x201
 [<ffffffff8121d4b4>] driver_register+0xa8/0x128
 [<ffffffff8126c748>] usb_register_driver+0x80/0xe4
 [<ffffffffa030d000>] ? wdm_init+0x0/0x20 [cdc_wdm]
 [<ffffffffa030d01e>] wdm_init+0x1e/0x20 [cdc_wdm]
 [<ffffffff8100a056>] do_one_initcall+0x56/0x13d
 [<ffffffff810612b3>] ? __blocking_notifier_call_chain+0x58/0x6a
 [<ffffffff8106f95a>] sys_init_module+0xa9/0x1c8
 [<ffffffff8101133a>] system_call_fastpath+0x16/0x1b
Code: 48 c7 83 08 01 00 00 0c 92 30 a0 66 89 43 68 48 8d 83 f8 00 00 00 48 89 83 f8 00 00 00 48 89 83 00 01 00 00 49 8b 06 4c 8b 60 10 <41> 0f b6 44 24 03 83 e0 03 83 f8 03 0f 85 27 02 00 00 41 80 7c
RIP  [<ffffffffa0308d00>] wdm_probe+0x1a0/0x424 [cdc_wdm]
 RSP <ffff88012715bcc8>
CR2: 0000000000000003
---[ end trace f1ff473594f6fa1e ]---
Comment 6 Chuck Ebbert 2009-03-26 18:22:13 EDT
Can you post (as an attachment) the output of lsusb -v with the phone connected? Just post the part for the phone itself if you can...
Comment 7 Heishiro Mitsurugi 2009-03-26 19:33:57 EDT
Hi.

I connected the phone, tried running lsusb -v and the command didn't return anything... I didn't get the prompt again in the terminal window. Seems to be frozen.

I'm going to restart the PC and try again... If the same thing happen i won't post anything.

Heishiro.
Comment 8 Tim Lauridsen 2009-03-27 11:35:47 EDT
i have tried it too.

lsusb -v goes into a deadlock an never returns

can't even kill the process with 'kill -9 <pid>'


(Running 2.6.27.19-170.2.35.fc10.i686)
Comment 9 Chuck Ebbert 2009-04-08 15:59:09 EDT
A fix that prevents the oops and will let you run the lsusb -v command went into kernel-2.6.27.21-170.2.44 ... when that or a later kernel gets built we'll need you to run that command so the underlying bug can be fixed and the device can be made to work.
Comment 10 Fedora Update System 2009-05-06 00:06:29 EDT
kernel-2.6.27.22-78.2.48.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/kernel-2.6.27.22-78.2.48.fc9
Comment 11 Heishiro Mitsurugi 2009-05-06 08:27:35 EDT
As soon as the kernel is available through yum, i will install it and try it out.

Heishiro
Comment 12 Fedora Update System 2009-05-09 00:15:43 EDT
kernel-2.6.27.22-78.2.48.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing-newkey update kernel'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2009-4547
Comment 13 Tim Lauridsen 2009-05-09 05:24:00 EDT
I have tested it on Fedora 11 ( 2.6.29.2-126.fc11.i586 ) and the phone (W380) is connecting with out any errors. (i was not working the last time i tried i F10 a while ago). 

dmesg:

usb 2-2: new full speed USB device using uhci_hcd and address 2
usb 2-2: New USB device found, idVendor=0fce, idProduct=d0b5
usb 2-2: New USB device strings: Mfr=1, Product=2, SerialNumber=3
usb 2-2: Product: Sony Ericsson W380
usb 2-2: Manufacturer: Sony Ericsson
usb 2-2: SerialNumber: 3550250217350870
usb 2-2: configuration #2 chosen from 1 choice
cdc_wdm: probe of 2-2:2.5 failed with error -22
usbcore: registered new interface driver cdc_wdm
cdc_acm 2-2:2.1: ttyACM0: USB ACM device
usbcore: registered new interface driver cdc_acm
cdc_acm: v0.26:USB Abstract Control Model driver for USB modems and ISDN adapters
usb 2-2: USB disconnect, address 2
usb 2-2: new full speed USB device using uhci_hcd and address 3
usb 2-2: New USB device found, idVendor=0fce, idProduct=e0b5
usb 2-2: New USB device strings: Mfr=1, Product=2, SerialNumber=3
usb 2-2: Product: Memory Stick
usb 2-2: Manufacturer: Sony Ericsson
usb 2-2: SerialNumber: 3550250217350870
usb 2-2: configuration #1 chosen from 1 choice
Initializing USB Mass Storage driver...
scsi6 : SCSI emulation for USB Mass Storage devices
usbcore: registered new interface driver usb-storage
USB Mass Storage support registered.
usb-storage: device found at 3
usb-storage: waiting for device to settle before scanning
usb-storage: device scan complete
scsi 6:0:0:0: Direct-Access     Sony Eri Memory Stick     0000 PQ: 0 ANSI: 0
sd 6:0:0:0: [sdb] 960512 512-byte hardware sectors: (491 MB/469 MiB)
sd 6:0:0:0: [sdb] Test WP failed, assume Write Enabled
sd 6:0:0:0: [sdb] Assuming drive cache: write through
sd 6:0:0:0: [sdb] 960512 512-byte hardware sectors: (491 MB/469 MiB)
sd 6:0:0:0: [sdb] Test WP failed, assume Write Enabled
sd 6:0:0:0: [sdb] Assuming drive cache: write through
 sdb: sdb1
sd 6:0:0:0: [sdb] Attached SCSI removable disk
sd 6:0:0:0: Attached scsi generic sg2 type 0
Comment 14 Heishiro Mitsurugi 2009-05-09 15:00:51 EDT
I updated the "testing" kernel using the instructions commented before, and after that rebooted and connected the phone to the PC.

The memory stick was properly found, and i was able to transfer files to the phone.

dmesg output:

usb 2-2: new full speed USB device using uhci_hcd and address 4
usb 2-2: configuration #1 chosen from 1 choice
usb 2-2: New USB device found, idVendor=0fce, idProduct=e0d0
usb 2-2: New USB device strings: Mfr=1, Product=2, SerialNumber=3
usb 2-2: Product: Memory Stick
usb 2-2: Manufacturer: Sony Ericsson
usb 2-2: SerialNumber: xxxxxxxxxxxxxxxxxx
Initializing USB Mass Storage driver...
scsi4 : SCSI emulation for USB Mass Storage devices
usbcore: registered new interface driver usb-storage
USB Mass Storage support registered.
usb-storage: device found at 4
usb-storage: waiting for device to settle before scanning
usb-storage: device scan complete
scsi 4:0:0:0: Direct-Access     Sony Eri Memory Stick     0000 PQ: 0 ANSI: 0
sd 4:0:0:0: [sde] 960512 512-byte hardware sectors (492 MB)
sd 4:0:0:0: [sde] Test WP failed, assume Write Enabled
sd 4:0:0:0: [sde] Assuming drive cache: write through
sd 4:0:0:0: [sde] 960512 512-byte hardware sectors (492 MB)
sd 4:0:0:0: [sde] Test WP failed, assume Write Enabled
sd 4:0:0:0: [sde] Assuming drive cache: write through
 sde: sde1
sd 4:0:0:0: [sde] Attached SCSI removable disk
sd 4:0:0:0: Attached scsi generic sg5 type 0
Comment 15 Heishiro Mitsurugi 2009-05-11 13:11:24 EDT
Not sure if this info is still needed... And in fact not sure if you need the complete lsusb -v. Here's the part that describes the phone using lsusb -v

If you need any other information, please let me know.


Bus 002 Device 004: ID 0fce:e0d0 Sony Ericsson Mobile Communications AB 
Device Descriptor:                                                      
  bLength                18                                             
  bDescriptorType         1                                             
  bcdUSB               2.00                                             
  bDeviceClass            0 (Defined at Interface level)                
  bDeviceSubClass         0                                             
  bDeviceProtocol         0                                             
  bMaxPacketSize0         8                                             
  idVendor           0x0fce Sony Ericsson Mobile Communications AB      
  idProduct          0xe0d0                                             
  bcdDevice            0.00                                             
  iManufacturer           1 Sony Ericsson                               
  iProduct                2 Memory Stick                                
  iSerial                 3 XXXXXXXXXXXXXXXXXXXX                            
  bNumConfigurations      1                                             
  Configuration Descriptor:                                             
    bLength                 9                                           
    bDescriptorType         2                                           
    wTotalLength           32                                           
    bNumInterfaces          1                                           
    bConfigurationValue     1                                           
    iConfiguration          4 MSC Device                                
    bmAttributes         0x80                                           
      (Bus Powered)                                                     
    MaxPower              500mA                                         
    Interface Descriptor:                                               
      bLength                 9                                         
      bDescriptorType         4                                         
      bInterfaceNumber        0                                         
      bAlternateSetting       0                                         
      bNumEndpoints           2                                         
      bInterfaceClass         8 Mass Storage                            
      bInterfaceSubClass      6 SCSI                                    
      bInterfaceProtocol     80 Bulk (Zip)                              
      iInterface              5 Sony Ericsson Memory Stick              
      Endpoint Descriptor:                                              
        bLength                 7                                       
        bDescriptorType         5                                       
        bEndpointAddress     0x03  EP 3 OUT                             
        bmAttributes            2                                       
          Transfer Type            Bulk                                 
          Synch Type               None                                 
          Usage Type               Data                                 
        wMaxPacketSize     0x0040  1x 64 bytes                          
        bInterval               0                                       
      Endpoint Descriptor:                                              
        bLength                 7                                       
        bDescriptorType         5                                       
        bEndpointAddress     0x83  EP 3 IN                              
        bmAttributes            2                                       
          Transfer Type            Bulk                                 
          Synch Type               None                                 
          Usage Type               Data                                 
        wMaxPacketSize     0x0040  1x 64 bytes                          
        bInterval               0                                       
Device Status:     0x0000                                               
  (Bus Powered)
Comment 16 Fedora Update System 2009-05-11 13:32:46 EDT
kernel-2.6.27.23-78.2.50.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/kernel-2.6.27.23-78.2.50.fc9
Comment 17 Fedora Update System 2009-05-12 00:00:19 EDT
kernel-2.6.27.23-78.2.50.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing-newkey update kernel'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2009-4754
Comment 18 Fedora Update System 2009-05-18 22:04:05 EDT
kernel-2.6.27.23-78.2.50.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.