Bug 481744 - [featurerequest] libgpod 0.7.0 is out
[featurerequest] libgpod 0.7.0 is out
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: libgpod (Show other bugs)
10
All Linux
low Severity low
: ---
: ---
Assigned To: Todd Zullinger
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-27 08:24 EST by Dmitrij S. Kryzhevich
Modified: 2009-07-02 23:21 EDT (History)
4 users (show)

See Also:
Fixed In Version: 0.7.0-1.fc10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-02 01:43:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch for kipi-plugins work with libgpod 0.7.0 (8.00 KB, patch)
2009-01-28 08:10 EST, Dmitrij S. Kryzhevich
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
KDE Software Compilation 181334 None None None Never

  None (edit)
Description Dmitrij S. Kryzhevich 2009-01-27 08:24:43 EST
libgpod 0.7.0 already out with almost all bugfixes except selinux one. It would be grate to see it in Fedora, and more better - in at least Fedora 10.
Comment 1 Todd Zullinger 2009-01-27 11:41:29 EST
The update also bumps the library soname, which means that we need to ensure that packages which depend on libgpod can be updated at the same time.  I've rebuilt most of the things in Fedora that depend on libgpod.so.3 locally, but kipi-plugins needs some work still still¹.  There are also a decent number of applications that make use of python-gpod which will need to be checked and possibly patched as well.  Until most of that work gets done, we can't really pull the updated libgpod into rawhide, let alone think of updating either of the stable branches.

Here are the packages that require libgpod and libgpod.so:

amarok
gnome-mplayer
gtkpod
kipi-plugins
lastfm
rhythmbox

(The gnome-mplayer and lastfm packages are in rpmfusion.  Only gnome-mplayer needs patched, which I have done locally but haven't tested yet.)

These are the packages that require python-gpod:

conduit
elisa
exaile
gpodder
quodlibet

I haven't looked at these yet to see what change any of them might need.  Any changes needed should be minimal, if they are needed at all.

¹ http://bugs.kde.org/show_bug.cgi?id=181334 - if you can help with any patches on this, it'd be most appreciated.  I filed the bug a week ago and haven't heard anything from the kipi-plugins folks yet.
Comment 2 Dmitrij S. Kryzhevich 2009-01-28 08:06:53 EST
Trunk Amarok really needs libgpod >= 0.7.0 (anybody force version check? yes, nobody, just existence) so in 2.1 it will be hard dep. What about kipi-plugins, kde bugzilla overloading now with kde4.2 release. I have prepared patch and will attach it here. When i can, i'l post it in kde #181334 bug.
Comment 3 Dmitrij S. Kryzhevich 2009-01-28 08:10:13 EST
Created attachment 330225 [details]
patch for kipi-plugins work with libgpod 0.7.0

These patch does not resolve inner kipi-plugins problems, just turn then in operation with newer libgpod.
Comment 4 Dmitrij S. Kryzhevich 2009-01-28 11:17:53 EST
Attach for kdebug #181334 added.
Comment 5 Todd Zullinger 2009-01-28 11:48:11 EST
Dmitrij, thanks for working on the patch.  I'll work on getting some builds together for testing.  My network connection might be spotty today though, so it might not be until later tonight or tomorrow.
Comment 6 Todd Zullinger 2009-02-22 12:09:46 EST
Sorry for the long delay.  I built libgpod for rawhide the other day, but it didn't make it into the repos before the scheduled buildsystem outage.  When the buildsystem returns, libgpod should hit the next rawhide that's built.

Unfortunately, both amarok and kipi-plugins had unrelated build failures.  So they need some work before they hit rawhide.

What was the selinux bug you mentioned?  I've used libgpod and gtkpod on my systems with selinux in enforcing mode for several releases and not noticed any issues or AVC denials.  If there are problems though, I'd like to see that we get them resolved.

Many thanks for the patches you submitted upstream!
Comment 7 Dmitrij S. Kryzhevich 2009-02-23 00:01:14 EST
As I know, Amarok strongly require Qt 4.4 for building, rawhide has qt 4.5, as well as gcc issue (no build tags found in koji for last build, may be they can help?).
kipi-plugins - I see, some phonon problems I can't undestand now.

What about selinux, I mean Fedora patch set for libgpod, there are for selinux one.
Comment 8 Todd Zullinger 2009-02-23 00:12:16 EST
(In reply to comment #7)
> As I know, Amarok strongly require Qt 4.4 for building, rawhide has qt 4.5, as
> well as gcc issue (no build tags found in koji for last build, may be they can
> help?).
> kipi-plugins - I see, some phonon problems I can't undestand now.

Rex Dieter said he'd take a look at amarok and kipi-plugins.  He's the
maintainer.  He'll hopefully have some ideas.  The problems shouldn't be
related to libgpod at least. ;)

> What about selinux, I mean Fedora patch set for libgpod, there are for selinux
> one.

Do you mean the small patch I have that changes the location that makes the
hal callout use /var/run/hald instead of /tmp to mount the ipod when reading
the SysInfoExtended data?  Or are there some other problems/patches for
libgpod and selinux?
Comment 9 Dmitrij S. Kryzhevich 2009-02-23 00:17:19 EST
After some thinking/testing: kipi-plugin have also qt 4.5 problem, not phonon. Imho, tags can help in this case too.

Conclusion: qt 4.5 and gcc issue, not amarok and kipi-plugins.

>Do you mean the small patch I have that changes the location that makes the
>hal callout use /var/run/hald instead of /tmp to mount the ipod when reading
>the SysInfoExtended data?

Yes.
Comment 10 Fedora Update System 2009-06-04 10:37:32 EDT
libgpod-0.7.0-1.fc10,amarok-2.1-1.fc10,gtkpod-0.99.14-1.fc10,kipi-plugins-0.3.0-1.fc10.1,rhythmbox-0.11.6-22.r6096.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/libgpod-0.7.0-1.fc10,amarok-2.1-1.fc10,gtkpod-0.99.14-1.fc10,kipi-plugins-0.3.0-1.fc10.1,rhythmbox-0.11.6-22.r6096.fc10
Comment 11 Fedora Update System 2009-06-15 22:25:05 EDT
libgpod-0.7.0-1.fc10, gtkpod-0.99.14-1.fc10, kipi-plugins-0.3.0-1.fc10.1, rhythmbox-0.11.6-22.r6096.fc10, amarok-2.1.1-1.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update libgpod gtkpod kipi-plugins rhythmbox amarok'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-6385
Comment 12 Fedora Update System 2009-06-19 09:34:02 EDT
libgpod-0.7.0-1.fc10, gtkpod-0.99.14-1.fc10, kipi-plugins-0.3.0-1.fc10.1, rhythmbox-0.11.6-22.r6096.fc10, amarok-2.1.1-1.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update libgpod gtkpod kipi-plugins rhythmbox amarok'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-6385
Comment 13 Fedora Update System 2009-07-02 01:43:01 EDT
libgpod-0.7.0-1.fc10, gtkpod-0.99.14-1.fc10, kipi-plugins-0.3.0-1.fc10.1, rhythmbox-0.11.6-22.r6096.fc10, amarok-2.1.1-1.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 14 Stuart D Gathman 2009-07-02 22:36:27 EDT
Attempt to apply updates fails with libgpod.so.3 required by package gnome.  Will try again tomorrow in case I'm not seeing some required updates.
Comment 15 Stuart D Gathman 2009-07-02 22:38:57 EDT
Resolving Dependencies
--> Running transaction check
---> Package kipi-plugins.i386 0:0.3.0-1.fc10.1 set to be updated
--> Processing Dependency: libgpod.so.3 for package: gnome-mplayer-0.9.5-3.fc10.i386
---> Package libgpod.i386 0:0.7.0-1.fc10 set to be updated
---> Package rhythmbox.i386 0:0.11.6-22.r6096.fc10 set to be updated
--> Finished Dependency Resolution
gnome-mplayer-0.9.5-3.fc10.i386 from installed has depsolving problems
  --> Missing Dependency: libgpod.so.3 is needed by package gnome-mplayer-0.9.5-3.fc10.i386 (installed)
Error: Missing Dependency: libgpod.so.3 is needed by package gnome-mplayer-0.9.5-3.fc10.i386 (installed)
 You could try using --skip-broken to work around the problem
 You could try running: package-cleanup --problems
                        package-cleanup --dupes
                        rpm -Va --nofiles --nodigest
Comment 16 Todd Zullinger 2009-07-02 23:21:14 EDT
These missing dependencies are packages from RPM Fusion.  You can either wait a day or so for the RPM Fusion repos to be updated and synced to their mirrors or enable the RPM Fusion *-testing repository which has the updated gnome-mplayer (and lastfm).

Note You need to log in before you can comment on or make changes to this bug.