Bug 481782 - scsi backend: make sure data is actually written to disk
scsi backend: make sure data is actually written to disk
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: xen (Show other bugs)
5.4
All Linux
urgent Severity medium
: rc
: ---
Assigned To: Rik van Riel
Virtualization Bugs
: ZStream
Depends On:
Blocks: 488698
  Show dependency treegraph
 
Reported: 2009-01-27 11:11 EST by Rik van Riel
Modified: 2010-10-23 03:15 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-02 06:05:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to flush data to disk (544 bytes, patch)
2009-01-27 11:11 EST, Rik van Riel
no flags Details | Diff

  None (edit)
Description Rik van Riel 2009-01-27 11:11:23 EST
Created attachment 330104 [details]
patch to flush data to disk

Description of problem:

The SCSI backend does not make sure data is actually written to disk before scsi_write_data() returns.  Calling bdrv_flush will fix this, in the exact same way we fixed it in the IDE emulation around RHEL 5 GA time.
Comment 2 Rik van Riel 2009-01-27 11:13:23 EST
This patch is not needed for upstream, because the bdrv_aio_* framework takes care of IO completion issues automatically.
Comment 5 Jiri Denemark 2009-03-05 03:55:01 EST
Fix built into xen-3.0.3-82.el5
Comment 9 Chris Ward 2009-07-03 14:22:08 EDT
~~ Attention - RHEL 5.4 Beta Released! ~~

RHEL 5.4 Beta has been released! There should be a fix present in the Beta release that addresses this particular request. Please test and report back results here, at your earliest convenience. RHEL 5.4 General Availability release is just around the corner!

If you encounter any issues while testing Beta, please describe the issues you have encountered and set the bug into NEED_INFO. If you encounter new issues, please clone this bug to open a new issue and request it be reviewed for inclusion in RHEL 5.4 or a later update, if it is not of urgent severity.

Please do not flip the bug status to VERIFIED. Only post your verification results, and if available, update Verified field with the appropriate value.

Questions can be posted to this bug or your customer or partner representative.
Comment 13 Yewei Shao 2009-07-28 04:20:30 EDT
Verified on xen-3.0.3-91.el5
Comment 15 errata-xmlrpc 2009-09-02 06:05:37 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-1328.html

Note You need to log in before you can comment on or make changes to this bug.