Bug 481797 - _getConfig() got an unexpected keyword argument 'enabled_plugins'
_getConfig() got an unexpected keyword argument 'enabled_plugins'
Status: CLOSED DUPLICATE of bug 481716
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-27 12:15 EST by Cole Robinson
Modified: 2009-01-27 12:47 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-27 12:47:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Full anaconda output. (53.44 KB, text/plain)
2009-01-27 12:17 EST, Cole Robinson
no flags Details

  None (edit)
Description Cole Robinson 2009-01-27 12:15:41 EST
Received the following error report trying to install rawhide today (on both a physical machine and a VM). I'll attach the full report.

==========================================


anaconda 11.5.0.11 exception report
Traceback (most recent call first):
  File "/usr/lib/anaconda/yuminstall.py", line 584, in doConfigSetup
    enabled_plugins=["whiteout", "blacklist"])
  File "/usr/lib/anaconda/yuminstall.py", line 300, in __init__
    self.doConfigSetup(root=anaconda.rootPath)
  File "/usr/lib/anaconda/yuminstall.py", line 1002, in doBackendSetup
    self.ayum = AnacondaYum(anaconda)
  File "/usr/lib/anaconda/backend.py", line 255, in doBackendSetup
    if anaconda.backend.doBackendSetup(anaconda) == DISPATCH_BACK:
  File "/usr/lib/anaconda/dispatch.py", line 204, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 127, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/dispatch.py", line 226, in currentStep
    self.gotoNext()
  File "/usr/lib/anaconda/text.py", line 677, in run
    (step, instance) = anaconda.dispatch.currentStep()
  File "/usr/bin/anaconda", line 1010, in <module>
    anaconda.intf.run(anaconda)
TypeError: _getConfig() got an unexpected keyword argument 'enabled_plugins'

Local variables in innermost frame:
self: <yuminstall.AnacondaYum object at 0x7fcefba2f9d0>
root: /mnt/sysimage
fn: /tmp/anaconda-yum.conf


Anaconda instance, containing members:
rescue_mount: True
intf: InstallInterface instance, containing members:
  intf.screen: SnackScreen instance, containing members:
    intf.screen.width: 80
    intf.screen.height: 24
  intf.instLanguage: Language instance, containing members:
    intf.instLanguage.targetLang: None
    intf.instLanguage.default: en_US
    intf.instLanguage.displayMode: t
    intf.instLanguage.current: en_US.UTF-8
rescue: False
updateSrc: None
mediaDevice: None
methodstr: http://mirrors.kernel.org/fedora/development/x86_64/os/
dispatch: <dispatch.Dispatcher object at 0x7fcefba1a850>
rootPath: /mnt/sysimage
xdriver: None
isKickstart: True
stage2: http://mirrors.kernel.org/fedora/development/x86_64/os//images/install.img
id: InstallData instance, containing members:
  id.firewall: Firewall instance, containing members:
    id.firewall.portlist: []
    id.firewall.servicelist: [ssh]
    id.firewall.trustdevs: []
    id.firewall.enabled: True
  id.anaconda: Already dumped
  id.upgradeRoot: None
  id.keyboard: Keyboard instance, containing members:
    id.keyboard.info: {'LAYOUT': us, 'KEYBOARDTYPE': pc, 'VARIANT': , 'KEYTABLE': us, 'MODEL': pc105+inet, 'OPTIONS': }
    id.keyboard.type: PC
    id.keyboard._mods: KeyboardModels instance, containing members:
    id.keyboard.beenset: 1
  id.timezone: Timezone instance, containing members:
    id.timezone.utc: False
    id.timezone.tz: America/New_York
  id.zfcp: ZFCP instance, containing members:
    id.zfcp.hasReadConfig: True
    id.zfcp.fcpdevs: []
  id.upgrade: False
  id.monitor: None
  id.iscsi: <iscsi.iscsi object at 0x7fcefba2f810>
  id.fsset: FileSystemSet instance, containing members:
    id.fsset.messageWindow: <bound method InstallInterface.messageWindow of <text.InstallInterface instance at 0x7fcefba17ab8>>
    id.fsset.volumesCreated: 1
    id.fsset.progressWindow: <bound method InstallInterface.progressWindow of <text.InstallInterface instance at 0x7fcefba17ab8>>
    id.fsset.migratedfs: 1
    id.fsset.waitWindow: <bound method InstallInterface.waitWindow of <text.InstallInterface instance at 0x7fcefba17ab8>>
    id.fsset.entries: [fsentry -- device: vda2   mountpoint: /
  fsystem: ext3 format: True
  ismounted: 1  options: 'defaults'
  label: / fsprofile: 

, fsentry -- device: vda1   mountpoint: /boot
  fsystem: ext3 format: True
  ismounted: 1  options: 'defaults'
  label: /boot fsprofile: 

, fsentry -- device: shm   mountpoint: /dev/shm
  fsystem: tmpfs format: 0
  ismounted: 0  options: 'defaults'
  label: None fsprofile: None

, fsentry -- device: devpts   mountpoint: /dev/pts
  fsystem: devpts format: 0
  ismounted: 0  options: 'gid=5,mode=620'
  label: None fsprofile: None

, fsentry -- device: sys   mountpoint: /sys
  fsystem: sysfs format: 0
  ismounted: 1  options: 'defaults'
  label: None fsprofile: None

, fsentry -- device: proc   mountpoint: /proc
  fsystem: proc format: 0
  ismounted: 1  options: 'defaults'
  label: None fsprofile: None

]
    id.fsset.mountcount: 4
  id.desktop: Desktop instance, containing members:
    id.desktop.info: {'DESKTOP': GNOME}
    id.desktop.runlevel: 5
  id.rootParts: None
  id.x_already_set: 0
  id.backend: YumBackend instance, containing members:
    id.backend.instPath: /mnt/sysimage
    id.backend.skipFormatRoot: False
    id.backend.instLog: None
    id.backend.supportsUpgrades: True
    id.backend._loopbackFile: None
    id.backend.supportsPackageSelection: True
  id.firstboot: 1
  id.diskset: DiskSet instance, containing members:
    id.diskset.initializedDisks: {'vda': True}
    id.diskset.disks: {'vda': <PedDisk object at 0x7fcf0e750e30>}
    id.diskset.anaconda: Already dumped
    id.diskset.devicesOpen: True
    id.diskset.onlyPrimary: None
  id.users: None
  id.displayMode: t
  id.auth: --useshadow  --passalgo=md5 --enablenis --nisdomain=redhat.com --nisserver=l2.corp.redhat.com --enablekrb5 --krb5realm=REDHAT.COM --krb5kdc=kerberos.corp.redhat.com:88 --krb5adminserver=kerberos.corp.redhat.com:749

Exception occurred during state dump:
Traceback (most recent call last):
  File "/usr/lib/anaconda/exception.py", line 219, in dump
    self._dumpClass(anaconda, fd, skipList=idSkipList)
  File "/usr/lib/anaconda/exception.py", line 161, in _dumpClass
    self._dumpClass(value, fd, level + 1, parentkey=curkey, skipList=skipList)
  File "/usr/lib/anaconda/exception.py", line 163, in _dumpClass
    fd.write("%s%s: %s\n" % (pad, curkey, value))
  File "/usr/lib/python2.6/site-packages/pykickstart/base.py", line 268, in __str__
    retval += obj.__str__()
  File "/usr/lib/python2.6/site-packages/pykickstart/commands/firewall.py", line 138, in __str__
    retval = F9_Firewall.__str__(self)
  File "/usr/lib/python2.6/site-packages/pykickstart/commands/firewall.py", line 41, in __str__
    retval = BaseData.__str__(self)
TypeError: unbound method __str__() must be called with BaseData instance as first argument (got Firewall instance instead)
Comment 1 Cole Robinson 2009-01-27 12:17:48 EST
Created attachment 330117 [details]
Full anaconda output.
Comment 3 Chris Lumens 2009-01-27 12:47:05 EST

*** This bug has been marked as a duplicate of bug 481716 ***

Note You need to log in before you can comment on or make changes to this bug.