Bug 481798 - clean F-10/kde-4.2.0 panel includes both guidance-power-manager and powerdevil
clean F-10/kde-4.2.0 panel includes both guidance-power-manager and powerdevil
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: kdebase-workspace (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
Depends On:
Blocks: kde42
  Show dependency treegraph
 
Reported: 2009-01-27 12:20 EST by Rex Dieter
Modified: 2009-02-09 13:31 EST (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-09 13:31:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rex Dieter 2009-01-27 12:20:21 EST
Looks like a fresh/clean F-10/kde-4.2.0 panel includes both guidance-power-manager and powerdevil, for F-9/F-10 this should at least stay with guidance (only)... for F11+ we will probably want powerdevil.

Looks like the battery-applet patch from 4.1 got lost and/or needs porting.
Comment 1 Anne 2009-01-28 05:52:23 EST
My netbook has a very recent F10 clean install, updated to 4.2.  Only Guidance appears on my panel.
Comment 2 Martin Kho 2009-01-28 06:52:06 EST
A fresh F10 + kde-redhat (4.2) install on a desktop pc, guidance didn't start with the message:
"guidance-power-manager(16477): Communication problem with "guidance-power-manager" , it probably crashed. Error message was: "org.freedesktop.DBus.Error.NoReply" : " "Message did not receive a reply (timeout by message bus)" "

Guidance-power-manager removed. Powerdevil is active but seems to be not working very well. Screen will not blank (DPMS).

Battary-applet does not show mouse battery status. Powerdevil did find 1 battery.

lshal:
udi = '/org/freedesktop/Hal/devices/usb_device_46d_c50e_noserial'
  battery.charge_level.current = 5  (0x5)  (int)
  battery.charge_level.design = 7  (0x7)  (int)
  battery.charge_level.last_full = 7  (0x7)  (int)
  battery.charge_level.percentage = 71  (0x47)  (int)
  battery.command_interface = 'csr'  (string)
  battery.csr.has_res = false  (bool)
  battery.csr.has_sms = false  (bool)
  battery.csr.is_dual = false  (bool)
  battery.is_rechargeable = true  (bool)
  battery.present = true  (bool)
  battery.type = 'mouse'  (string)
  info.addons = {'hald-addon-usb-csr'} (string list)
  info.bus = 'usb_device'  (string)
  info.capabilities = {'battery'} (string list)
  info.category = 'battery'  (string)
  info.linux.driver = 'usb'  (string)
  info.parent = '/org/freedesktop/Hal/devices/usb_device_1d6b_1_0000_00_1d_0'  (string)
  info.product = 'MX1000 Laser Mouse'  (string)
  info.subsystem = 'usb_device'  (string)
  info.udi = '/org/freedesktop/Hal/devices/usb_device_46d_c50e_noserial'  (string)
  info.vendor = 'Logitech, Inc.'  (string)
  linux.device_file = '/dev/bus/usb/005/002'  (string)
  linux.hotplug_type = 2  (0x2)  (int)
  linux.subsystem = 'usb'  (string)
  linux.sysfs_path = '/sys/devices/pci0000:00/0000:00:1d.0/usb5/5-1'  (string)
Comment 3 Ngo Than 2009-01-28 07:37:13 EST
>Looks like the battery-applet patch from 4.1 got lost and/or needs porting.
yes, it's fixing it. It will be included in next build
Comment 4 Ngo Than 2009-01-28 07:48:18 EST
Rex, could you please try kdebase-workspace-4.2.0-2? thanks
Comment 5 Jaroslav Reznik 2009-01-28 11:08:26 EST
After update to 4.2.0 from kde-redhat I have both but interesting thing is - Guidance is showing correctly one battery, Power devil doesn't. 

Than: I'll try it
Comment 6 Rex Dieter 2009-01-28 11:22:05 EST
kdebase-workspace-4.2.0-2 confirmed good.
Comment 7 Tomas Miljenović (TomasM) 2009-01-29 21:26:51 EST
Rex: With latest testing packages from kde-redhat on FC10 and Guidance uninstalled, PowerDevil works nicely for me.
Comment 8 Kevin Kofler 2009-02-09 13:31:03 EST
Fixed in the latest 4.2 testing update, 4.1 not affected, closing.

Note You need to log in before you can comment on or make changes to this bug.