Bug 4824 - rpm -F query fails w/ redhat updates, other suggestions
rpm -F query fails w/ redhat updates, other suggestions
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
6.0
i386 Linux
low Severity low
: ---
: ---
Assigned To: Jeff Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-09-01 07:28 EDT by Pekka Savola
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-09-01 09:52:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pekka Savola 1999-09-01 07:28:42 EDT
I have all redhat errata updates in this one local
directory.  If I do:

rpm -F *.rpm, it says:

query of XFree86-cyrillic-fonts-3.3.3.1-52.i386.rpm failed
query of XFree86-cyrillic-fonts-3.3.3.1-52.i386.rpm failed
rpm: no packages given for install

I don't have any X packages installed (this is just a
bare-bones install).

Also a little suggestion: I'd like rpm -Fh --quiet *.rpm (or
some similar command) wouldn't report :

rpm: no packages given for install

This would make rpm -F nicer to implement in upgrade scripts
because you wouldn't need to redirect the output (thus also
losing some vital information, in case something is
upgraded) or create some klugdy scripts that'd tailor the
output in some way.
Comment 1 Jeff Johnson 2001-01-08 14:36:39 EST
This bug is probably moot, as --freshen is implemented in C in rpm-3.0.5 and
later.

Note You need to log in before you can comment on or make changes to this bug.