Bug 48241 - can't use created devices on floppy disks
Summary: can't use created devices on floppy disks
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel
Version: 7.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-07-09 22:41 UTC by Brian Mitchell
Modified: 2007-04-18 16:34 UTC (History)
0 users

(edit)
Clone Of:
(edit)
Last Closed: 2001-07-09 22:41:43 UTC


Attachments (Terms of Use)

Description Brian Mitchell 2001-07-09 22:41:39 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows NT 5.0)

Description of problem:
Access to device nodes stored on a floppy disk fails. I've reproduced this 
on three seperate redhat systems (only 2 of which installed by me). Debian 
was also tested, using kernel 2.2, it did not appear to be affected.

I tried to build a stock 2.2 kernel, and that also appeared to fail, but 
that is a seperate unrelated matter.

How reproducible:
Always

Steps to Reproduce:
1.mke2fs /dev/fd0
note: I tried making a minix filesystem as well, the results did
not change.
2.mount /mnt/floppy
3.cd /mnt/floppy
4.cp -R /dev/null .
5.cat null
<this should fail>
6.cat /dev/null
<this should not fail>

If this is tried on other block devices (tried ide drives, scsi drives, 
even a ramdisk) it works as one would expect.
	

Actual Results:  cat of the version of null on floppy:
cat: null: Permission Denied

cat of the version of null in /dev:
<just another prompt, as expected>


Expected Results:  the two cat commands should produce identical results.

Additional info:

according to strace, the error recieved is EACCESS. As I mentioned, this 
only occurs on floppy disks. I can't reproduce it on any other block 
device.

Comment 1 Brian Mitchell 2001-07-11 22:42:44 UTC
operator error. I did not notice that fstab has nodev for /mnt/floppy. doh.



Note You need to log in before you can comment on or make changes to this bug.