Bug 482748 - Red Hat Network (RHN) Hosted website session times out too quickly
Red Hat Network (RHN) Hosted website session times out too quickly
Status: CLOSED CURRENTRELEASE
Product: Red Hat Network
Classification: Red Hat
Component: RHN/Web Site (Show other bugs)
rhn506
All Linux
high Severity high
: ---
: ---
Assigned To: Sebastian Skracic
Red Hat Network Quality Assurance
Rally US461
:
Depends On: 554797
Blocks: rhn-sprint33
  Show dependency treegraph
 
Reported: 2009-01-27 16:01 EST by James Antill
Modified: 2010-10-23 03:16 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-03-17 19:29:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description James Antill 2009-01-27 16:01:56 EST
Description of problem:
 This has no happened twice, so I'm pretty sure I'm not imagining it anymore.

Steps to Reproduce:
1. goto rhn.redhat.com
2. goto alter channel subscriptions for a host
3. click one or more "Additional Services Channels"
4. click alter subscriptions
5. click on another one
6. wait for cookie to timeout (luckily it only takes about half a second, or maybe 30 minutes).
7. click alter subscriptions
8. login
9. All the channels will now be "unticked" ... and indeed your client box won't have those repos. enabled anymore.
Comment 1 James Antill 2009-01-27 16:16:19 EST
Just did it again but instead of clicking a channel on at steop #5 I clicked one off.
Comment 2 Chris Duryee 2009-02-02 11:14:30 EST
The root issue is that the user gets logged out at seemingly random intervals while using RHN. It could be 2 minutes, or 30. Everything looks OK to me on the prod servers, I thought maybe there was an issue with ticket cache propagation.
Comment 3 Xixi 2009-09-23 16:18:23 EDT
Customer faces frequent session timeout issues from RHN Hosted. When they login to RHN Hosted (web-ui) session gets expired very quickly (avg 10-15 min) and they need to re-login.

Also see customer reporting this issue on rhn-users (public mailing list).
https://www.redhat.com/archives/rhn-users/2009-September/msg00038.html
Comment 6 Grant Gainey 2009-11-03 17:05:13 EST
An update, for anyone who's following this:  

we've done a lot of investigation recently, trying to track this down.  That it *only* happens in production makes that even more exciting.  At this point, what we believe is happening is a combination of three (or possibly four) problems, *all* of which need to be addressed to fix the symptom.  (Which is part of why it hasn't been fixed it sooner, because individual "fixes" didn't seem to address the problem)

RHN and thw WAPPS folks are going down a few paths tp come up with a fix for the problem.  we'll let people know here, once we have something concrete to report.
Comment 7 Sebastian Skracic 2009-11-06 05:16:24 EST
Preliminary work has been wrapped in

dbchange: 30df79722210e70d7dc42dec366c78b790963fbd
code: 68fc3ac80a3e53d253b3e725c7f9a3b4c704d401
Comment 8 Denise Hughes 2009-11-12 10:43:20 EST
Verified on webdev
Comment 10 daryl herzmann 2009-12-01 14:57:06 EST
Any updates on getting this into production? thanks!
Comment 13 daryl herzmann 2010-02-12 10:48:57 EST
Will this be fixed during the March 13th RHN scheduled outage?
Comment 14 Denise Hughes 2010-02-12 12:57:17 EST
Daryl,

This has been verified in webqa and will be pushed to production with other RHN Hosted changes for the RHEL6 release.

Note You need to log in before you can comment on or make changes to this bug.