Bug 482785 - DHCP always fails on first try
DHCP always fails on first try
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
10
i386 Linux
low Severity medium
: ---
: ---
Assigned To: David Cantrell
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-27 22:59 EST by Kevin Arhelger
Modified: 2009-02-20 22:08 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-20 22:08:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kevin Arhelger 2009-01-27 22:59:58 EST
Description of problem:
Anaconda always fails to bring up eth0 via dhcp.

Version-Release number of selected component (if applicable):
Anaconda shipped on Fedora 10 32bit.

How reproducible:
Every Time

Steps to Reproduce:
1. Boot Fedora 10 32bit install media and append ks="http://example.com/kickstart"
 (Or use koan/cobbler)
2. Wait for the network portion to start.

Actual results:
Anaconda fails to bring up eth0 via dhcp.

Expected results:
Dhcp successfully completes.

Additional info:
Manually hitting enter ("Retry") will instantly allow Anaconda to continue successfully.
Apparently not card dependent, bug on at least the following cards.

02:08.0 Ethernet controller: Intel Corporation 82801DB PRO/100 VE (LOM) Ethernet Controller (rev 81)

02:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 01)

It's a blocker bug for me, as I am trying to kickstart a lab. Having to hit enter on each machine does not allow unattended installs.
Comment 1 David Cantrell 2009-02-18 18:43:20 EST
Are you able to try rawhide and see if this is still happening?  I ask because this bug sounds familiar to a problem we solved recently in rawhide.

https://fedoraproject.org/wiki/Releases/Rawhide
Comment 2 Kevin Arhelger 2009-02-18 18:52:07 EST
I can respin a revisor image to try. What would the appropriate way to include just Rawhide anaconda into a respin?
Comment 3 David Cantrell 2009-02-19 12:52:04 EST
Including just anaconda from rawhide won't work because a lot has changed in anaconda and the things it requires are different.

It would probably be easiest to just try boot.iso from rawhide.  Those would normally appear in these directories:
http://download.fedora.redhat.com/pub/fedora/linux/development/i386/os/images/
http://download.fedora.redhat.com/pub/fedora/linux/development/x86_64/os/images/
http://download.fedora.redhat.com/pub/fedora/linux/development/ppc/os/images/

If one is missing, it means the tree build for that architecture did not complete for the night (for one reason or another).
Comment 4 David Cantrell 2009-02-20 22:08:33 EST
I'm still unable to reproduce this on rawhide over the past week.

Note You need to log in before you can comment on or make changes to this bug.