Bug 482792 - Enable CONFIG_PCI_STUB
Enable CONFIG_PCI_STUB
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Mark McLoughlin
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks: F11VirtTarget
  Show dependency treegraph
 
Reported: 2009-01-28 02:44 EST by Mark McLoughlin
Modified: 2009-01-30 13:25 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-30 13:25:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mark McLoughlin 2009-01-28 02:44:47 EST
The pci-stub module is needed for KVM Device Assignment so that we can prevent any driver in the host from binding to a device which has been assigned to the guest. It was first added in 2.6.29.

http://lkml.org/lkml/2008/11/26/11
https://fedoraproject.org/wiki/Features/KVM_PCI_Device_Assignment
Comment 1 Mark McLoughlin 2009-01-28 02:52:24 EST
Fixed in kernel-2.6.29-0.59.rc2.git3.fc11

* Wed Jan 28 2009 Mark McLoughlin <markmc@redhat.com>
- Enable CONFIG_PCI_STUB for KVM (#482792)
Comment 2 Mark McLoughlin 2009-01-28 03:26:35 EST
Or maybe not, the build failed on ppc:

drivers/gpu/drm/nouveau/nouveau_state.c: In function 'nouveau_load':
drivers/gpu/drm/nouveau/nouveau_state.c:487: error: implicit declaration of function '___swab32'
make[4]: *** [drivers/gpu/drm/nouveau/nouveau_state.o] Error 1

http://koji.fedoraproject.org/koji/getfile?taskID=1088040&name=build.log
Comment 3 Mark McLoughlin 2009-01-30 13:25:16 EST
Okay, since built

Note You need to log in before you can comment on or make changes to this bug.