Bug 482818 - Mksquashfs and Kernel
Mksquashfs and Kernel
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: livecd-tools (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Fedora Extras Quality Assurance
:
: 473162 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-28 07:46 EST by CAI Qian
Modified: 2009-01-28 10:54 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-28 10:12:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description CAI Qian 2009-01-28 07:46:43 EST
Description of problem:
If I used F10 to create a rawhide livecd. The livecd would not be able to boot,

SQUASHFS error: Major/Minor mismatch, older Squashfs 3.1 filesystems
are unsupported.

This was because the host was using squashfs-tools-3.4-1, while the livecd had 2.6.29 kernel with squashfs 4.0, which break the back compatibility.

It was also a boot failure when using 4.0 version of squshfs-tools to create a 2.6.27 kernel based F10 livecd.

SQUASHFS error: Major/Minor mismatch, newer Squashfs 4.0 filesystems
are unsupported.

Version-Release number of selected component (if applicable):
squashfs-tools-3.4-1.x86_64
livecd-tools-020-1.fc10.x86_64

How reproducible:
always

Steps to Reproduce:
1. livecd-creator --config=/usr/share/doc/livecd-tools-020/livecd-fedora-minimal.ks
  
Actual results:
Livecd failed to boot in initramfs.

Expected results:
Livecd boot.
Comment 1 CAI Qian 2009-01-28 09:48:27 EST
*** Bug 473162 has been marked as a duplicate of this bug. ***
Comment 2 Jeremy Katz 2009-01-28 10:12:12 EST
Yep, squashfs broke compatibility.  There's not anything we can do about this in livecd-tools.
Comment 3 CAI Qian 2009-01-28 10:54:48 EST
Well, how about to add a check for kernel version installed in livecd while running mksquashfs to reject incompatible attempts?

Note You need to log in before you can comment on or make changes to this bug.