Bug 48283 - Write() system call slow down when filesystem full
Write() system call slow down when filesystem full
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-07-09 22:17 EDT by Shinya Narahara
Modified: 2007-04-18 12:34 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-06 10:24:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
test program about this issue. (1.01 KB, text/plain)
2001-07-09 22:18 EDT, Shinya Narahara
no flags Details

  None (edit)
Description Shinya Narahara 2001-07-09 22:17:28 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.75 [ja] (WinNT; U)

Description of problem:
When I make a big file(ex. 500Mbyte or more) to make filesystem be full
and add more data onto it, the system response becomes slow.


How reproducible:
Always

Steps to Reproduce:
1.compile additional program
2.run it(for 5minites). 
3.if it's stopped because of write() error(=filesystem full), stop and rerun it.


Actual Results:  Write() system call takes 2000ns or so.

Expected Results:  Write() system call should return immediately upto 5ns.
Normal kernel(Linus released, not patched by redhat) do so.


Additional info:

We tested it on the redhat kernel from 2.4.2-2 to 2.4.3-12, and got
same results. Normal kernel(Linus released) 2.4.2 to 2.4.5
doesn't have this issue.

The reason we think this is problem, for example, when syslog daemon
writes much system log into syslog file(and filesystem is full),
system load becomes higher and higher. Now we have this phenomenon.
We know we might avoid this to avoid filesystem full someway, but
why normal kernel doesn't have this issue?
Comment 1 Shinya Narahara 2001-07-09 22:18:47 EDT
Created attachment 23147 [details]
test program about this issue.

Note You need to log in before you can comment on or make changes to this bug.