Bug 482855 - rpm-build should depend on redhat-rpm-config
Summary: rpm-build should depend on redhat-rpm-config
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: comps
Version: 10
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Tom "spot" Callaway
URL:
Whiteboard:
: 506915 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-01-28 15:42 UTC by Matěj Cepl
Modified: 2018-04-11 08:25 UTC (History)
12 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-14 16:00:53 UTC


Attachments (Terms of Use)

Description Matěj Cepl 2009-01-28 15:42:17 UTC
Description of problem:
I have installed fresh Fedora 10.x86_64 just with minimal set of packages (every checkbox in the installer was cleared). Then installed rpm-build (among other packages) and run rpmbuild --rebuild on one of my packages. To my surprise no -debuginfo package was build. After discussion on the internal IRC somebody suggested installing redhat-rpm-config. THat helped.

Why isn't redhat-rpm-config installed automagically whenever rpm-build is?

Version-Release number of selected component (if applicable):
rpm-build-4.6.0-0.rc3.1.fc10.x86_64
redhat-rpm-config-9.0.3-3.fc10.noarch


How reproducible:
100%

Steps to Reproduce:
1.see above
2.
3.
  
Actual results:
no -debuginfo packages are built

Expected results:
they should be

Additional info:

Comment 1 James M. Leddy 2009-02-19 16:35:50 UTC
Why should this strictly *depend* on rpm-build?  Maybe some people would like to build *without* -debuginfo packages.  If there's a dependency that won't be a problem.  Or maybe they have their own config package that does things differently.

I think what's needed is better documentation.  I had to DAFS to figure this one out when I had the issue.

Comment 2 Panu Matilainen 2009-06-22 13:22:18 UTC
*** Bug 506915 has been marked as a duplicate of this bug. ***

Comment 3 Panu Matilainen 2009-07-14 09:29:20 UTC
Building packages "the Fedora way" requires having redhat-rpm-config installed, but rpm (including rpmbuild) doesn't require it to function and there are perfectly valid use-cases where you would *not* want redhat-rpm-config installed. Request it to be added to core/base group in comps if you want but having rpmbuild require redhat-rpm-config would be wrong when it's not a strict requirement.

Comment 4 Marcela Mašláňová 2009-07-14 09:38:28 UTC
I'd like to have redhat-rpm-config in core/base group because of this problem.

Comment 6 Tom "spot" Callaway 2009-09-14 14:48:27 UTC
Bill, any plans to add redhat-rpm-config to core or base?

Comment 7 Bill Nottingham 2009-09-14 16:00:53 UTC
That would conflict with the other bug w.r.t. removing perl deps from base.

It's installed in all the same groups as rpm-build; that's the best we can do for now.

Comment 8 Qian Cai 2010-04-09 02:12:58 UTC
*** Bug 580619 has been marked as a duplicate of this bug. ***

Comment 9 Paul Wouters 2012-06-17 00:49:03 UTC
As I said on the list:

Someone building non-fedora/non-epel rpms should be expected to create
their own version of foo-rpm-config that satisfies/obsoletes the same
dependancy as redhat-rpm-config.

group names are no replacements for proper dependancies. People who
build rpms need to be able to "yum install rpmbuild" and get a working
setup. They should not need to spend an hour googling on why their
debuginfo packages don't get build.

If people wish to leave out the dependancy, which I believe is wrong, then they should ensure we get a clearer error on why debuginfo packages are failing to be built, and provide a hint to the user to perhaps install redhat-rpm-config

Comment 10 Jens Petersen 2012-06-18 06:47:24 UTC
+1 for adding it to @base.


Note You need to log in before you can comment on or make changes to this bug.