Bug 482890 - deletion of test sources causes info test traceback
deletion of test sources causes info test traceback
Status: CLOSED ERRATA
Product: Red Hat Hardware Certification Program
Classification: Red Hat
Component: Test Suite (tests) (Show other bugs)
5
All Linux
low Severity medium
: ---
: ---
Assigned To: Greg Nichols
Lawrence Lim
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-28 12:55 EST by Greg Nichols
Modified: 2014-03-25 20:56 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: ====== if test sources are deleted from /usr/share/hts/tests, the info test will traceback when it tries to copy modified sources. Consequence: ============ traceback error Fix: ==== hardwaretest.py patch to catch OSError exception for missing directory Result: ======= no more traceback errors caused by this
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-27 12:34:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
hardwaretest.py patch to catch OSError exception for missing directory (1.39 KB, patch)
2009-05-27 14:24 EDT, Greg Nichols
no flags Details | Diff

  None (edit)
Description Greg Nichols 2009-01-28 12:55:24 EST
Description of problem:

if test sources are deleted from /usr/share/hts/tests, the info test will traceback when it tries to copy modified sources.

Version-Release number of selected component (if applicable):

HTS 5.3 R15
Comment 1 Greg Nichols 2009-05-27 14:24:37 EDT
Created attachment 345658 [details]
hardwaretest.py patch to catch OSError exception for missing directory
Comment 4 Nan Zhang 2009-08-13 05:55:47 EDT
Verified with v7-1.0-14.el5 on RHEL5u4-Server-i386, no issue found.
Comment 7 YangKun 2009-08-21 06:07:14 EDT
Release note added. If any revisions are required, please set the 
"requires_release_notes" flag to "?" and edit the "Release Notes" field accordingly.
All revisions will be proofread by the Engineering Content Services team.

New Contents:
Cause:
======
if test sources are deleted from /usr/share/hts/tests, the info test will traceback when it tries to copy modified sources.

Consequence:
============
traceback error

Fix:
====
hardwaretest.py patch to catch OSError exception for missing directory 

Result:
=======
no more traceback errors caused by this
Comment 8 errata-xmlrpc 2009-08-27 12:34:45 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-1234.html

Note You need to log in before you can comment on or make changes to this bug.