Bug 482901 - Konqueror dosn`t work with flash objects
Summary: Konqueror dosn`t work with flash objects
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: kdebase
Version: 10
Hardware: i386
OS: Linux
low
medium
Target Milestone: ---
Assignee: Than Ngo
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: kde42
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-01-28 18:39 UTC by Andreas Utterberg
Modified: 2009-02-19 11:43 UTC (History)
8 users (show)

Fixed In Version: KDE 4.2.0
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-02-19 11:43:00 UTC


Attachments (Terms of Use)

Description Andreas Utterberg 2009-01-28 18:39:52 UTC
Description of problem:
Konqueror dosn`t work with flash objects like youtube and other flash components. Flash works ok in Firefox, when listing plugins in Konqueror the Flash components are there with urls to folder $HOME/.mozilla/plugins where libflashplayer.so is located.

Version-Release number of selected component (if applicable):

rpm -qa | grep kdebase
kdebase-workspace-libs-4.1.4-1.fc10.i386
kdebase-4.1.4-2.fc10.i386
kdebase-workspace-4.1.4-1.fc10.i386
kdebase-runtime-4.1.4-1.fc10.i386
kdebase-runtime-libs-4.1.4-1.fc10.i386
kdebase-libs-4.1.4-2.fc10.i386

Flash player 10.

How reproducible:
Try to watch a flash clip.

Steps to Reproduce:
1. Browse to a page containing a flash object.

  
Actual results:
Nothing is showing.

Expected results:
The flash object to play in the browser.

Additional info:

Comment 1 Kevin Kofler 2009-01-28 19:43:59 UTC
The kdebase4 package is obsolete (it was only used when KDE 4 was not the default) and no longer exists since Fedora 9, there's kdebase, kdebase-runtime and kdebase-workspace. Konqueror is part of kdebase.

Comment 2 Rex Dieter 2009-02-04 13:04:14 UTC
Interesting, this works for me fine on i386 (with kde-4.1.x)

I pleasantly discovered yesterday, that kde-4.2.0 also makes x86_64 + nspluginwrapper + flash-plugin work too. woo.

I'll put it on the kde42 tracker, when kde-4.2.0 lands in updates, please confirm if this is still an issue for you.

Comment 3 Stan Trzmiel 2009-02-09 17:30:12 UTC
Flash video is a bit unreliable under Konqueror. Ssometimes it works from the first try sometimes flash loads but doesn't load the video stream and I have to hit "refresh" few times.

IIRC it start to happend when adobe dropped support for non-gecko based browsers.

On the other hand flash animations runs ok, including all those nasty ads on webpages.


Note You need to log in before you can comment on or make changes to this bug.