Bug 482918 - do_timer_interrupt() does not acquire or release xtime_lock
do_timer_interrupt() does not acquire or release xtime_lock
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
4.8
i386 Linux
medium Severity medium
: rc
: ---
Assigned To: Prarit Bhargava
Martin Jenner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-28 14:52 EST by Prarit Bhargava
Modified: 2009-01-29 08:56 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-29 08:56:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Prarit Bhargava 2009-01-28 14:52:28 EST
Description of problem:

do_timer_interrupt does not acquire or release the xtime_lock (which is a sequential lock) when servicing the timer interrupt.  The rest of the i386 timing code does use the lock and we've imported a lot of code into RHEL4 which uses the xtime_lock.

Version-Release number of selected component (if applicable):  2.6.9-80.el4

I can almost guarantee that some of the timing instability is due to this missing lock.

This issue, however, maybe moot.  RHEL4 is almost at the end of its life, and I'm not sure we should change this behavior now.  OTOH, as mentioned, using the lock in do_timer_interrupt() will certainly increase stability in gettimeofday calls, system time, etc.

P.

Note You need to log in before you can comment on or make changes to this bug.