Bug 482924 - ppc64 X crash: "Fatal server error: SELinux: Failed to set up security class mapping"
ppc64 X crash: "Fatal server error: SELinux: Failed to set up security class ...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: libselinux (Show other bugs)
rawhide
ppc64 Linux
low Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Fedora Extras Quality Assurance
: SELinux
Depends On:
Blocks: F11Blocker/F11FinalBlocker
  Show dependency treegraph
 
Reported: 2009-01-28 15:40 EST by Will Woods
Modified: 2009-03-03 15:04 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-03 15:04:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg.0.log showing crash (37.30 KB, text/plain)
2009-01-29 13:42 EST, Will Woods
no flags Details

  None (edit)
Description Will Woods 2009-01-28 15:40:23 EST
Running F11Alpha anaconda (11.5.0.11) on a G5 Power Mac (ppc64, radeon video) Xorg crashes at startup with this message:

Fatal server error: SELinux: Failed to set up security class mapping

Booting with 'enforcing=0' gives the same result, but 'selinux=0' allows Xorg to start and run normally.
Comment 1 Matěj Cepl 2009-01-28 18:46:50 EST
Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf, if available) and X server log file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file attachments using the bugzilla file attachment link below.

Could you please also try to run without any /etc/X11/xorg.conf (if you have one) whatsoever and let X11 autodetect your display and video card? Attach to this bug /var/log/Xorg.0.log from this attempt as well, please.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 2 Will Woods 2009-01-29 13:42:18 EST
Created attachment 330393 [details]
Xorg.0.log showing crash

There is no xorg.conf. Interesting dmesg lines:

PCI: Non-PCI map for f0000000, prot: 32b
ioctl32(Xorg:2472): Unknown cmd fd(0) cmd(80086408){t:'d';sz:8} arg(ffc57768) on
 /var/log/Xorg.0.log
ioctl32(Xorg:2472): Unknown cmd fd(0) cmd(80086408){t:'d';sz:8} arg(ffc57768) on
 /var/log/Xorg.0.log
Comment 3 Will Woods 2009-01-29 13:45:45 EST
This happens outside of anaconda as well, so it's not specific to the installer environment. Haven't tried 32-bit ppc, but this problem doesn't manifest on x86_64 or i386.

Judging by the ioctl() messages in dmesg, it's possible that Xorg is doing the right thing and this is a kernel problem with SELinux on ppc.
Comment 4 Will Woods 2009-01-29 14:18:29 EST
After talking to dwalsh I'm pretty sure this is a problem with Xorg's SELinux extension.

Creating an xorg.conf that contains:
  Section "Extensions"
      Option "SELinux" "Disable"
  EndSection
lets X start up normally.
Comment 7 Adam Jackson 2009-02-08 02:11:04 EST
Will, can you try again with xorg-x11-server-1.5.99.902-4.fc11 once it's built?
Comment 8 Adam Jackson 2009-02-08 02:12:00 EST
That was needlessly terse.  -4 includes a strerror() dump at the point where that fails, so hopefully we'll get some better idea of why it hates us.
Comment 9 Will Woods 2009-02-09 16:33:05 EST
Unfortunately, no:
  SELinux: Failed to set up security class mapping, Success
Comment 10 Will Woods 2009-02-17 19:42:59 EST
By which I mean: no, strerror() is unhelpfully giving an error of "Success". 

Changed summary since this happens outside of anaconda.
Comment 11 Josh Boyer 2009-02-24 14:02:45 EST
I still see this on a dual G5 with:

xorg-x11-server-Xorg-1.5.99.903-3.fc11.ppc
xorg-x11-server-common-1.5.99.903-3.fc11.ppc
xorg-x11-drv-evdev-2.1.99-1.20090219.fc11.ppc
xorg-x11-drv-ati-6.10.0-3.fc11.ppc
Comment 12 Eric Paris 2009-03-02 11:19:18 EST
http://userspace.selinuxproject.org/trac/changeset/b27ff3397dcef05a4a22343dccf18f3a29b7de90

Lets me start Xvfb on a ppc64 machine.  dwalsh can you integrate and build a new libselinux ?
Comment 13 Daniel Walsh 2009-03-03 15:04:48 EST
Fixed in libselinux-2.0.78-1.fc11

Note You need to log in before you can comment on or make changes to this bug.