Bug 482934 - gwave won't plot data and crashes.
gwave won't plot data and crashes.
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: gwave (Show other bugs)
10
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Chitlesh GOORAH
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-28 16:38 EST by Robin
Modified: 2009-03-29 09:16 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-29 09:16:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Output file from the tutorial. (13.35 KB, text/plain)
2009-01-28 16:38 EST, Robin
no flags Details

  None (edit)
Description Robin 2009-01-28 16:38:31 EST
Created attachment 330286 [details]
Output file from the tutorial.

Description of problem:
Gwave won't plot any data and crashes from time to time.  

Version-Release number of selected component (if applicable):
gwave-2-11.20070514snap.fc10.x86_64

How reproducible:
Every time I try it won't plot or read the file normally.

Steps to Reproduce:
1.Open Gwave
2. Click File > Read File
3. Try a different file.
  
Actual results:
No plot of data.  Headers can be read sometimes.  Trying a second file can cause a crash.

Expected results:
Normally plotting of data.

Additional info:
I am running gwave from a terminal in KDE 4.1 desktop.

Error messages on starting gwave.
  WARNING: (gnome gtk gdk-event): `initialize' imported from both (gnome gw generics) and (oop goops)

The only error message on crash is "Aborted."

While loading a file.
  with-selected "Datafile to load" save=#f defname=#f
  chose file(Datafile to load): "~/mycircuit.out"

I was trying to do this tutorial.
  http://www.johannes-bauer.com/electronics/

I have included the mycircuit.out as described in the tutorial.

To me this is a high priority for processing some data.
Comment 1 Chitlesh GOORAH 2009-01-28 17:27:23 EST
If it is high priority, I'll welcome you try to LabPlot

yum install LabPlot

while I'm trying to fix gwave.

I have recommended LabPlot as an alternative to gwave in the past on my blog. Unfortunately gwave gets easily broken.

http://clunixchit.blogspot.com/search?q=LabPlot

E.g for your attachment:

LabPlot
import mycircuit.out
click ok
Speadsheet -> Plot -> Plot 2D

Change your colour if needed.
Comment 2 Robin 2009-01-29 09:30:52 EST
I have installed LabPlot as I was going to try it on my new F10 install.  It worked but I need to play a bit more with it and colours do need changing.  

Thanks for the quick guide to using it.  I have lowered the priority due to having a work around.

I am going to try gwave on two other machines, both i386 installs to see if there is a difference.
Comment 3 Chitlesh GOORAH 2009-03-02 07:14:59 EST
Hello robin, it seems that the gwave on F-11-development does not suffer from this. I'll continue with the testing before updating the F-10 gwave.

Note You need to log in before you can comment on or make changes to this bug.