Bug 482960 - Please update httpd to 2.2.11 as this is now current build of apache
Please update httpd to 2.2.11 as this is now current build of apache
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: httpd (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Joe Orton
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-28 20:19 EST by David
Modified: 2009-03-25 12:09 EDT (History)
2 users (show)

See Also:
Fixed In Version: 2.2.11-2.fc10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-25 12:09:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David 2009-01-28 20:19:41 EST
Description of problem:

Please update httpd to 2.2.11 as this is now current build of apache.

I already rpmbuilt a 2.2.11-1 from rawhide 2.2.11-6 just changed the pid back to /var/run/httpd.pid instead of the new /var/run/httpd/httpd.pid as used in rawhide build (I dont know why they moved the PID).  I even backported to a Fedora 8 server running Plesk and it runs fine.  Plesk hates the pid not being in /var/run/httpd.pid as does psmon.

If for some reason the new location is required, can a symlink be added to the old location not to break psmon / plesk and other programs that monitor the normal pid locations?

There are mod_security rule processing failed issues that have plagued apache for ages with all previous versions of httpd up to and including 2.2.10, but ever since building 2.2.11 they are gone at last.

Can this be pushed to testing please for F10?

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Fedora Update System 2009-03-09 18:54:53 EDT
httpd-2.2.11-2.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update httpd'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-2487
Comment 2 Fedora Update System 2009-03-11 13:59:47 EDT
httpd-2.2.11-2.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update httpd'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-2487
Comment 3 Fedora Update System 2009-03-25 12:08:46 EDT
httpd-2.2.11-2.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.