Bug 482967 - vpnc default route changed unexpectedly
vpnc default route changed unexpectedly
Status: CLOSED DUPLICATE of bug 479317
Product: Fedora
Classification: Fedora
Component: NetworkManager-vpnc (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-28 22:13 EST by Warren Togami
Modified: 2009-02-03 14:38 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-03 14:38:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Warren Togami 2009-01-28 22:13:48 EST
NetworkManager-0.7.0-1.git20090102.fc10.x86_64
NetworkManager-vpnc-0.7.0-1.svn13.fc10.x86_64

Some recent version of NetworkManager or NetworkManager-vpnc changed the default behavior of how vpnc had worked for many years.

Before the default was for vpnc to route only defined routes through the vpnc tunnel.  But now the default is to route the default route through the vpnc tunnel.  This shift in behavior was unexpected and without user visibility. possibly leading to data routing over networks which it was not intended.

"Use this connection only for resources on its network" checkbox

This option should be enabled by default, with the option to disable if that behavior is truly desired.
Comment 1 Dan Williams 2009-02-03 14:38:57 EST
This behavior had only been the case for NetworkManager-vpnc from 2008-10-10 to 2008-12-09.  By default, with NetworkManager-vpnc, *all* traffic would be routed through the VPN connection, unless you added routes manually.

In the next update, connections with manual routes will get the "Only use this connection for resources..." checked by default.  This fix was committed to applet SVN on 2009-02-01.  This has only been the case with Fedora 10 NetworkManager since the F-9 NetworkManager never got into -updates, but was only in updates-testing.

*** This bug has been marked as a duplicate of bug 479317 ***

Note You need to log in before you can comment on or make changes to this bug.