Bug 483002 - Debugging output written to terminal
Debugging output written to terminal
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: bash (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Roman Rakus
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-29 04:29 EST by Behdad Esfahbod
Modified: 2014-01-12 19:08 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-06 06:06:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Behdad Esfahbod 2009-01-29 04:29:17 EST
When I run something like:

$ find /usr | while read x; do ls "$x"; done >/dev/null

I start getting lots of bash debug output on the terminal:

TRACE: pid 24674: realloc_jobs_list: resize jobs list from 128 to 136
TRACE: pid 24674: realloc_jobs_list: j_lastj changed from 127 to 127
TRACE: pid 24674: realloc_jobs_list: j_njobs changed from 128 to 128
TRACE: pid 24674: realloc_jobs_list: js.j_ndead 128 js.c_reaped 128
TRACE: pid 24674: realloc_jobs_list: reset js.j_current (-1) and js.j_previous (-1)
TRACE: pid 24674: compact_jobs_list: returning 128
TRACE: pid 24674: realloc_jobs_list: resize jobs list from 136 to 144
TRACE: pid 24674: realloc_jobs_list: j_lastj changed from 135 to 135
TRACE: pid 24674: realloc_jobs_list: j_njobs changed from 136 to 136
TRACE: pid 24674: realloc_jobs_list: js.j_ndead 136 js.c_reaped 136
TRACE: pid 24674: realloc_jobs_list: reset js.j_current (-1) and js.j_previous (-1)

...

bash-4.0-0.1.rc1.fc11.i386
Comment 1 Roman Rakus 2009-01-29 09:31:19 EST
Thanks for report. It is because I forget to disable DEBUG mode. Now, with bash-4.0-0.3.rc1.fc11 it should be ok.
Comment 2 Roman Rakus 2009-05-06 06:06:13 EDT
It's ok -> closing.

Note You need to log in before you can comment on or make changes to this bug.