Bug 483031 - "init 1" does not work for xen virtual machines
"init 1" does not work for xen virtual machines
Status: CLOSED DUPLICATE of bug 471123
Product: Fedora
Classification: Fedora
Component: upstart (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Casey Dahlin
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-29 07:46 EST by Jan ONDREJ
Modified: 2014-06-18 04:46 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-29 13:01:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan ONDREJ 2009-01-29 07:46:30 EST
Description of problem:
When trying to boot to runlevel "1" (by adding 1 as kernel parameter or by running "init 1"), system is in state, where I can't do anything.

Version-Release number of selected component (if applicable):
[root@builder ~]# rpm -q upstart kernel
upstart-0.3.9-19.fc10.x86_64
kernel-2.6.27.12-170.2.5.fc10.x86_64
[root@builder ~]# uname -a
Linux builder.salstar.sk 2.6.27.12-170.2.5.fc10.x86_64 #1 SMP Wed Jan 21 01:33:24 EST 2009 x86_64 x86_64 x86_64 GNU/Linux


How reproducible:
always

Steps to Reproduce:
1. init 1
  
Actual results:
init: rc1 post-stop process (2321) terminated with status 1

Expected results:
running shell without other services started

Additional info:
After "rc1" message cursor is blinking, but I can't type commands. I only can restart my machine by xen command "xm reboot builder".

"init S" or adding "S" into kernel parameters works fine.
Comment 1 Bill Nottingham 2009-01-29 09:27:19 EST
Not sure why this would be xen-specific at all.

If you change the last bit of /etc/event.d/rc1 to 'exec strace telinit S', does it show any obvious failure point?
Comment 2 Jan ONDREJ 2009-01-29 10:55:12 EST
(In reply to comment #1)
> Not sure why this would be xen-specific at all.

May be because console is on /dev/hvc and not on standard /dev/console.
I am not sure.

> If you change the last bit of /etc/event.d/rc1 to 'exec strace telinit S', does
> it show any obvious failure point?

Nothing changed. Tryed to change this and run "init 1" and also start kernel with parameter "1". Exactly same output as before (I have strace installed on my system).
Comment 3 Bill Nottingham 2009-01-29 11:41:26 EST
What happens if you change it to 'clear || :'?
Comment 4 Jan ONDREJ 2009-01-29 11:45:01 EST
(In reply to comment #3)
> What happens if you change it to 'clear || :'?

post-stop script
        clear
        TEXTDOMAIN=initscripts
        . /etc/profile.d/lang.sh
        echo $"Telling INIT to go to single user mode."
        #exec telinit S
        exec clear || :
end script

File /etc/event.d/rc1 saved


Nothing changed.
Comment 5 Bill Nottingham 2009-01-29 11:46:56 EST
Oops, I think I remember now what this is. Does the patch in http://git.fedorahosted.org/git/?p=initscripts.git;a=commitdiff;h=0320082b72105bb90863d43b3051623381cde73a work for you?

If so, we'll get this cherry-picked to the F10 branch for a future update.
Comment 6 Jan ONDREJ 2009-01-29 12:18:13 EST
(In reply to comment #5)
> Oops, I think I remember now what this is. Does the patch in
> http://git.fedorahosted.org/git/?p=initscripts.git;a=commitdiff;h=0320082b72105bb90863d43b3051623381cde73a
> work for you?

Yes. Works. Just another problem:
  https://bugzilla.redhat.com/show_bug.cgi?id=483088
Comment 7 Bill Nottingham 2009-01-29 13:01:48 EST

*** This bug has been marked as a duplicate of bug 471123 ***

Note You need to log in before you can comment on or make changes to this bug.