Bug 483039 - wrong initscript behaviour
wrong initscript behaviour
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: netdump (Show other bugs)
4.8
All Linux
low Severity medium
: rc
: ---
Assigned To: Neil Horman
qe-baseos-daemons
:
Depends On:
Blocks: 237789
  Show dependency treegraph
 
Reported: 2009-01-29 08:45 EST by Karel Volný
Modified: 2011-01-07 11:27 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-01-07 11:27:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to correct initscript behavior (3.91 KB, patch)
2009-09-16 09:02 EDT, Neil Horman
no flags Details | Diff

  None (edit)
Description Karel Volný 2009-01-29 08:45:20 EST
Description of problem:
when the service is not configured, trying to start the service, the netdump initscript does not return error code 6 which should be used in that case (according to http://intranet.corp.redhat.com/ic/intranet/InitscriptsSpec.html)

the initscript even does not output the usage message in that case

in addition, the initscript refuses to do any other action if the configuration file is completely missing, and just returns zero for any action

the status return code for stopped service is 0 while it should be 3

Version-Release number of selected component (if applicable):
netdump-0.7.16-15

How reproducible:
always

Steps to Reproduce:
1. remove NETDUMPADDR record from /etc/sysconfig/netdump
2. service netdump start; echo $?
3. service netdump; echo $?
4. rm /etc/sysconfig/netdump
5. service netdump; echo $?
6. echo "NETDUMPADDR=server" > /etc/sysconfig/netdump
7. service netdump status; echo $?

Actual results:
Server address not specified in /etc/sysconfig/netdump
1
Server address not specified in /etc/sysconfig/netdump
1
0
netdump module not loaded
netconsole module not loaded
0

Expected results:
Server address not specified in /etc/sysconfig/netdump
6
Usage: service netdump {start|stop|status|restart|condrestart|propagate}
2
Usage: service netdump {start|stop|status|restart|condrestart|propagate}
2
netdump module not loaded
netconsole module not loaded
3


Additional info:
see also http://intranet.corp.redhat.com/ic/intranet/InitscriptGuidelines.html
Comment 1 Karel Volný 2009-02-10 06:57:17 EST
I made a RHTS test for the iniscript behaviour: /CoreOS/netdump/Regression/bz483039-initscript - review welcome ...
Comment 4 Neil Horman 2009-09-16 09:02:35 EDT
Created attachment 361273 [details]
patch to correct initscript behavior

please give that  a try and let me know if it passes the RHTS test
Comment 5 Karel Volný 2010-02-25 09:38:17 EST
(In reply to comment #4)
> Created an attachment (id=361273) [details]
> patch to correct initscript behavior
> 
> please give that  a try and let me know if it passes the RHTS test

yep, a lot better but there are still some problems:

- the Usage message does not mention the "reload" action

- the test with unprivileged user fails

- the initscript does not check for the stale lock

and the -server initscript was left untouched ...

but as RHEL-4 is nearly dead (ahem :-)) and I don't see netdump in RHEL-6 nor recent Fedora to propagate the changes forward, I'm not sure if that is worth fixing - if a update is ever going to be released, let's include this patch
Comment 6 RHEL Product and Program Management 2010-10-22 14:48:57 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 7 Neil Horman 2011-01-05 10:55:20 EST
Karel, can this be closed as a wontfix, its looking like we're not going to pull this into 4.9
Comment 8 Karel Volný 2011-01-07 10:26:55 EST
(In reply to comment #7)
> Karel, can this be closed as a wontfix, its looking like we're not going to
> pull this into 4.9

if there is no netdump update planned in RHEL4 then yes, closing this is the best thing to do

Note You need to log in before you can comment on or make changes to this bug.